aboutsummaryrefslogtreecommitdiff
path: root/tests/hash/CMakeLists.txt
diff options
context:
space:
mode:
authorSChernykh <sergey.v.chernykh@gmail.com>2019-02-04 17:49:19 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-02-14 14:44:27 +0000
commit1b77e80a7851a0a69da1111db0b4be8f3e668884 (patch)
tree015ac287c1f4a21623abc1ff4ef5b23464318007 /tests/hash/CMakeLists.txt
parentslow-hash: some more big endian fixes (diff)
downloadmonero-1b77e80a7851a0a69da1111db0b4be8f3e668884.tar.xz
Cryptonight variant 4 aka CryptonightR
It introduces random integer math into the main loop.
Diffstat (limited to 'tests/hash/CMakeLists.txt')
-rw-r--r--tests/hash/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/hash/CMakeLists.txt b/tests/hash/CMakeLists.txt
index 433cf94e9..105cf2c13 100644
--- a/tests/hash/CMakeLists.txt
+++ b/tests/hash/CMakeLists.txt
@@ -43,7 +43,7 @@ set_property(TARGET hash-tests
PROPERTY
FOLDER "tests")
-foreach (hash IN ITEMS fast slow slow-1 slow-2 tree extra-blake extra-groestl extra-jh extra-skein)
+foreach (hash IN ITEMS fast slow slow-1 slow-2 slow-4 tree extra-blake extra-groestl extra-jh extra-skein)
add_test(
NAME "hash-${hash}"
COMMAND hash-tests "${hash}" "${CMAKE_CURRENT_SOURCE_DIR}/tests-${hash}.txt")