summaryrefslogtreecommitdiff
path: root/x11-libs/xcb-proto
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xcb-proto')
-rw-r--r--x11-libs/xcb-proto/Manifest2
-rw-r--r--x11-libs/xcb-proto/files/digest-xcb-proto-99990
-rw-r--r--x11-libs/xcb-proto/xcb-proto-9999.ebuild33
3 files changed, 35 insertions, 0 deletions
diff --git a/x11-libs/xcb-proto/Manifest b/x11-libs/xcb-proto/Manifest
new file mode 100644
index 00000000..79b55698
--- /dev/null
+++ b/x11-libs/xcb-proto/Manifest
@@ -0,0 +1,2 @@
+MD5 513db039976616b008707ce4b860db81 xcb-proto-9999.ebuild 540
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-xcb-proto-9999 0
diff --git a/x11-libs/xcb-proto/files/digest-xcb-proto-9999 b/x11-libs/xcb-proto/files/digest-xcb-proto-9999
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/x11-libs/xcb-proto/files/digest-xcb-proto-9999
diff --git a/x11-libs/xcb-proto/xcb-proto-9999.ebuild b/x11-libs/xcb-proto/xcb-proto-9999.ebuild
new file mode 100644
index 00000000..3c695c72
--- /dev/null
+++ b/x11-libs/xcb-proto/xcb-proto-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit cvs
+
+ECVS_SERVER="cvs.freedesktop.org:/cvs/xcb"
+ECVS_MODULE="${PN}"
+
+DESCRIPTION="XCB-Proto"
+HOMEPAGE="http://freedesktop.org/Software/xcb"
+
+LICENSE="AS-IS"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/check
+ dev-util/pkgconfig
+ dev-libs/libxslt"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_compile()
+{
+ ./autogen.sh || die "autogen.sh failed"
+ econf || die "econf failed"
+}
+
+src_install()
+{
+ einstall || die "einstall failed"
+}