summaryrefslogtreecommitdiff
path: root/x11-libs
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/evas/Manifest2
-rw-r--r--x11-libs/evas/evas-9999-r1.ebuild73
-rw-r--r--x11-libs/evas/files/digest-evas-9999-r10
-rw-r--r--x11-libs/xau/Manifest2
-rw-r--r--x11-libs/xau/files/digest-xau-99990
-rw-r--r--x11-libs/xau/xau-9999.ebuild32
-rw-r--r--x11-libs/xcb-proto/Manifest2
-rw-r--r--x11-libs/xcb-proto/files/digest-xcb-proto-99990
-rw-r--r--x11-libs/xcb-proto/xcb-proto-9999.ebuild33
-rw-r--r--x11-libs/xcb-util/Manifest2
-rw-r--r--x11-libs/xcb-util/files/digest-xcb-util-99990
-rw-r--r--x11-libs/xcb-util/xcb-util-9999.ebuild63
-rw-r--r--x11-libs/xcb/Manifest2
-rw-r--r--x11-libs/xcb/files/digest-xcb-99990
-rw-r--r--x11-libs/xcb/xcb-9999.ebuild36
-rw-r--r--x11-libs/xproto/Manifest2
-rw-r--r--x11-libs/xproto/files/digest-xproto-99990
-rw-r--r--x11-libs/xproto/xproto-9999.ebuild31
18 files changed, 280 insertions, 0 deletions
diff --git a/x11-libs/evas/Manifest b/x11-libs/evas/Manifest
new file mode 100644
index 00000000..a902433b
--- /dev/null
+++ b/x11-libs/evas/Manifest
@@ -0,0 +1,2 @@
+MD5 e689b560f34033c73f2be54444d504a2 evas-9999-r1.ebuild 2385
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-evas-9999-r1 0
diff --git a/x11-libs/evas/evas-9999-r1.ebuild b/x11-libs/evas/evas-9999-r1.ebuild
new file mode 100644
index 00000000..0aadebbd
--- /dev/null
+++ b/x11-libs/evas/evas-9999-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/evas-9999.ebuild,v 1.7 2005/05/20 23:04:52 vapier Exp $
+
+inherit enlightenment flag-o-matic
+
+DESCRIPTION="hardware-accelerated canvas API"
+
+IUSE="X directfb fbcon jpeg mmx opengl png sse cairo xcb"
+
+DEPEND="virtual/x11
+ >=media-libs/imlib2-1.2.0
+ >=dev-libs/eet-0.9.9
+ >=dev-db/edb-1.0.5
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ directfb? ( >=dev-libs/DirectFB-0.9.16 )
+ cairo? ( >=x11-libs/cairo-0.2.0 )
+ xcb? ( x11-libs/xcb
+ x11-libs/xcb-util )
+ dev-util/pkgconfig"
+
+src_compile() {
+ # other *very* fun options:
+ # --enable-cpu-p2-only enable assumption of pentium2/amd cpu
+ # --enable-cpu-p3-only enable assumption of pentium3 and up cpu
+ # --enable-cpu-mmx enable mmx code
+ # --enable-cpu-sse enable sse code
+ # --enable-scale-sample enable sampling scaler code
+ # --enable-scale-smooth enable sampling scaler code
+ # --enable-scale-trilinear enable tri-linear scaler code
+ export MY_ECONF="
+ $(use_enable mmx cpu-mmx) \
+ $(use_enable sse cpu-mmx) \
+ $(use_enable sse cpu-sse) \
+ $(use_enable X software-x11) \
+ $(use_enable xcb software-xcb) \
+ $(use_enable opengl gl-x11) \
+ $(use_enable cairo cairo-x11) \
+ $(use_enable directfb) \
+ $(use_enable fbcon fb) \
+ --enable-image-loader-eet \
+ --enable-image-loader-edb \
+ --enable-fmemopen \
+ --enable-cpu-c \
+ --enable-scale-smooth \
+ --enable-scale-sample \
+ --enable-convert-8-rgb-332 \
+ --enable-convert-8-rgb-666 \
+ --enable-convert-8-rgb-232 \
+ --enable-convert-8-rgb-222 \
+ --enable-convert-8-rgb-221 \
+ --enable-convert-8-rgb-111 \
+ --enable-convert-16-rgb-565 \
+ --enable-convert-16-rgb-555 \
+ --enable-convert-16-rgb-444 \
+ --enable-convert-16-rgb-rot-0 \
+ --enable-convert-16-rgb-rot-270 \
+ --enable-convert-16-rgb-rot-90 \
+ --enable-convert-24-rgb-888 \
+ --enable-convert-24-bgr-888 \
+ --enable-convert-32-rgb-8888 \
+ --enable-convert-32-rgbx-8888 \
+ --enable-convert-32-bgr-8888 \
+ --enable-convert-32-bgrx-8888 \
+ --enable-convert-32-rgb-rot-0 \
+ --enable-convert-32-rgb-rot-270 \
+ --enable-convert-32-rgb-rot-90 \
+ $(use_enable png image-loader-png) \
+ $(use_enable jpeg image-loader-jpeg)
+ "
+ enlightenment_src_compile
+}
diff --git a/x11-libs/evas/files/digest-evas-9999-r1 b/x11-libs/evas/files/digest-evas-9999-r1
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/x11-libs/evas/files/digest-evas-9999-r1
diff --git a/x11-libs/xau/Manifest b/x11-libs/xau/Manifest
new file mode 100644
index 00000000..91d514b3
--- /dev/null
+++ b/x11-libs/xau/Manifest
@@ -0,0 +1,2 @@
+MD5 22838af1dd34824bffda13643009947d xau-9999.ebuild 526
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-xau-9999 0
diff --git a/x11-libs/xau/files/digest-xau-9999 b/x11-libs/xau/files/digest-xau-9999
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/x11-libs/xau/files/digest-xau-9999
diff --git a/x11-libs/xau/xau-9999.ebuild b/x11-libs/xau/xau-9999.ebuild
new file mode 100644
index 00000000..5f3a9bad
--- /dev/null
+++ b/x11-libs/xau/xau-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit cvs
+
+ECVS_SERVER="cvs.freedesktop.org:/cvs/xlibs"
+ECVS_MODULE="Xau"
+
+DESCRIPTION="Xau"
+HOMEPAGE="http://freedesktop.org/Software/xlibs"
+
+LICENSE="AS-IS"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/xproto"
+RDEPEND=""
+
+S=${WORKDIR}/Xau
+
+src_compile()
+{
+ ./autogen.sh || die "autogen.sh failed"
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ einstall || die "einstall failed"
+}
diff --git a/x11-libs/xcb-proto/Manifest b/x11-libs/xcb-proto/Manifest
new file mode 100644
index 00000000..79b55698
--- /dev/null
+++ b/x11-libs/xcb-proto/Manifest
@@ -0,0 +1,2 @@
+MD5 513db039976616b008707ce4b860db81 xcb-proto-9999.ebuild 540
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-xcb-proto-9999 0
diff --git a/x11-libs/xcb-proto/files/digest-xcb-proto-9999 b/x11-libs/xcb-proto/files/digest-xcb-proto-9999
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/x11-libs/xcb-proto/files/digest-xcb-proto-9999
diff --git a/x11-libs/xcb-proto/xcb-proto-9999.ebuild b/x11-libs/xcb-proto/xcb-proto-9999.ebuild
new file mode 100644
index 00000000..3c695c72
--- /dev/null
+++ b/x11-libs/xcb-proto/xcb-proto-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit cvs
+
+ECVS_SERVER="cvs.freedesktop.org:/cvs/xcb"
+ECVS_MODULE="${PN}"
+
+DESCRIPTION="XCB-Proto"
+HOMEPAGE="http://freedesktop.org/Software/xcb"
+
+LICENSE="AS-IS"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/check
+ dev-util/pkgconfig
+ dev-libs/libxslt"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_compile()
+{
+ ./autogen.sh || die "autogen.sh failed"
+ econf || die "econf failed"
+}
+
+src_install()
+{
+ einstall || die "einstall failed"
+}
diff --git a/x11-libs/xcb-util/Manifest b/x11-libs/xcb-util/Manifest
new file mode 100644
index 00000000..308cda1a
--- /dev/null
+++ b/x11-libs/xcb-util/Manifest
@@ -0,0 +1,2 @@
+MD5 bbde456f8d6c5aed5b106ec9edbda322 xcb-util-9999.ebuild 1684
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-xcb-util-9999 0
diff --git a/x11-libs/xcb-util/files/digest-xcb-util-9999 b/x11-libs/xcb-util/files/digest-xcb-util-9999
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/x11-libs/xcb-util/files/digest-xcb-util-9999
diff --git a/x11-libs/xcb-util/xcb-util-9999.ebuild b/x11-libs/xcb-util/xcb-util-9999.ebuild
new file mode 100644
index 00000000..e120c90c
--- /dev/null
+++ b/x11-libs/xcb-util/xcb-util-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit cvs
+
+ECVS_SERVER="cvs.freedesktop.org:/cvs/xcb"
+ECVS_MODULE="${PN}"
+
+DESCRIPTION="XCB-util"
+HOMEPAGE="http://freedesktop.org/Software/xcb"
+
+LICENSE="AS-IS"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/gperf
+ x11-libs/xcb"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_compile()
+{
+ ./autogen.sh || die "autogen.sh failed"
+ econf || die "econf failed"
+
+ # emake failed because of atom which is broken so made one per one
+ # Resolved with DEPEND gperf (Thanks to caro)
+
+ # Must be done before all (need by icccm)
+ #emake -C atom xcb_atom.h || die "emake -C atom xcb_atom.h failed"
+ #emake -C atom xcb-atom.pc || die "emake -C atom xcb-atom.pc failed"
+
+ #emake -C icccm || die "emake -C icccm failed"
+ #emake -C event || die "emake -C event failed"
+ #emake -C property || die "emake -C property failed"
+ #emake -C image || die "emake -C image failed"
+
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ einstall || die "einstall failed"
+
+ #einstall -C icccm || die "einstall -C icccm failed"
+ #einstall -C event || die "einstall -C event failed"
+ #einstall -C property || die "einstall -C property failed"
+ #einstall -C image || die "einstall -C image failed"
+
+ # Need FEATURES="-sandbox" or a patch (didn't find the way to avoid ACCESS
+ # VIOLATION)
+ # Now ok
+ ##emake -C atom install-pkgconfigDATA || die "emake -C atom install-pkgconfigDATA failed"
+ ##emake -C atom install-xcbincludeHEADERS || die "emake -C atom install-xcbincludeHEADERS failed"
+
+ #insinto /usr/include/X11/XCB/
+ #doins ${S}/atom/xcb_atom.h
+
+ #insinto /usr/lib/pkgconfig
+ #doins ${S}/atom/xcb-atom.pc
+}
diff --git a/x11-libs/xcb/Manifest b/x11-libs/xcb/Manifest
new file mode 100644
index 00000000..5527e1c7
--- /dev/null
+++ b/x11-libs/xcb/Manifest
@@ -0,0 +1,2 @@
+MD5 69c438cfcea0f148cea47ff971df19ea xcb-9999.ebuild 655
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-xcb-9999 0
diff --git a/x11-libs/xcb/files/digest-xcb-9999 b/x11-libs/xcb/files/digest-xcb-9999
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/x11-libs/xcb/files/digest-xcb-9999
diff --git a/x11-libs/xcb/xcb-9999.ebuild b/x11-libs/xcb/xcb-9999.ebuild
new file mode 100644
index 00000000..b18608b5
--- /dev/null
+++ b/x11-libs/xcb/xcb-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit cvs
+
+ECVS_SERVER="cvs.freedesktop.org:/cvs/xcb"
+ECVS_MODULE="${PN}"
+
+DESCRIPTION="XCB (Xlib remplacement)"
+HOMEPAGE="http://freedesktop.org/Software/xcb"
+
+LICENSE="AS-IS"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/check
+ x11-libs/xcb-proto
+ x11-libs/xau
+ x11-libs/xproto"
+RDEPEND=""
+
+S=${WORKDIR}/xcb
+
+src_compile()
+{
+ ./autogen.sh || die "autogen.sh failed"
+ econf || die "econf failed"
+ emake || die "emake failed
+ If you get error messages about -lXCB reemerge it with -j1"
+}
+
+src_install()
+{
+ einstall || die "einstall failed"
+}
diff --git a/x11-libs/xproto/Manifest b/x11-libs/xproto/Manifest
new file mode 100644
index 00000000..4322813b
--- /dev/null
+++ b/x11-libs/xproto/Manifest
@@ -0,0 +1,2 @@
+MD5 5fb66e323fa463406e5d665c2cdea324 xproto-9999.ebuild 491
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-xproto-9999 0
diff --git a/x11-libs/xproto/files/digest-xproto-9999 b/x11-libs/xproto/files/digest-xproto-9999
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/x11-libs/xproto/files/digest-xproto-9999
diff --git a/x11-libs/xproto/xproto-9999.ebuild b/x11-libs/xproto/xproto-9999.ebuild
new file mode 100644
index 00000000..ff8951c6
--- /dev/null
+++ b/x11-libs/xproto/xproto-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit cvs
+
+ECVS_SERVER="cvs.freedesktop.org:/cvs/xlibs"
+ECVS_MODULE="Xproto"
+
+DESCRIPTION="Xproto"
+HOMEPAGE="http://freedesktop.org/Software/xlibs"
+
+LICENSE="AS-IS"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/Xproto
+
+src_compile()
+{
+ ./autogen.sh || die "autogen.sh failed"
+ econf || die "econf failed"
+}
+
+src_install()
+{
+ einstall || die "einstall failed"
+}