summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trezor/trezor-0.13.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/trezor/trezor-0.13.0.ebuild b/dev-python/trezor/trezor-0.13.0.ebuild
index 54671dee..78c88ab2 100644
--- a/dev-python/trezor/trezor-0.13.0.ebuild
+++ b/dev-python/trezor/trezor-0.13.0.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 bash-completion-r1 udev
DESCRIPTION="Python client for communicating with TREZOR Hardware Wallet"
@@ -36,3 +37,11 @@ python_install_all() {
newbashcomp bash_completion.d/trezorctl.sh trezorctl
distutils-r1_python_install_all
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}