summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2022-11-30 20:39:03 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2022-11-30 20:39:03 +0000
commitdb14de56fdfbdd90fd6f0ee5c028975aef70fd16 (patch)
treed751854bfcb0e31f8cfab985004d0bc2b2b3ce12 /dev-python
parentdev-python/shamir-mnemonic: disable py3.8 (diff)
downloadportage-db14de56fdfbdd90fd6f0ee5c028975aef70fd16.tar.xz
dev-python/trezor: disable py3.8
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trezor/trezor-0.13.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/trezor/trezor-0.13.0.ebuild b/dev-python/trezor/trezor-0.13.0.ebuild
index 54671dee..78c88ab2 100644
--- a/dev-python/trezor/trezor-0.13.0.ebuild
+++ b/dev-python/trezor/trezor-0.13.0.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 bash-completion-r1 udev
DESCRIPTION="Python client for communicating with TREZOR Hardware Wallet"
@@ -36,3 +37,11 @@ python_install_all() {
newbashcomp bash_completion.d/trezorctl.sh trezorctl
distutils-r1_python_install_all
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}