summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-01-11 19:04:27 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-01-12 02:38:54 +0000
commite5fe34b067b9189e92684b238de8f340d7aeccda (patch)
treef5940804581ce6bf9fb1d9da1ffeb7c65bd7adfa /www-apps
parentwww-apps/phabricator: version bump (diff)
downloadportage-e5fe34b067b9189e92684b238de8f340d7aeccda.tar.xz
www-apps/phabricator-extensions-Sprint: version bump
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phabricator-extensions-Sprint/files/20180823-Remove-getCustomCapabilities.patch43
-rw-r--r--www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20191219.ebuild (renamed from www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20180823.ebuild)6
-rw-r--r--www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-9999.ebuild7
3 files changed, 9 insertions, 47 deletions
diff --git a/www-apps/phabricator-extensions-Sprint/files/20180823-Remove-getCustomCapabilities.patch b/www-apps/phabricator-extensions-Sprint/files/20180823-Remove-getCustomCapabilities.patch
deleted file mode 100644
index db24bb09..00000000
--- a/www-apps/phabricator-extensions-Sprint/files/20180823-Remove-getCustomCapabilities.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 7f34f377a425e0a53504355e991d9ccf4eb40de6 Mon Sep 17 00:00:00 2001
-From: epriestley <git@epriestley.com>
-Date: Wed, 22 Aug 2018 19:45:26 -0500
-Subject: [PATCH] Remove getCustomCapabilities
-
-see https://phabricator.wikimedia.org/T90906#4525254
----
- src/application/SprintApplication.php | 24 ------------------------
- 1 file changed, 24 deletions(-)
-
-diff --git a/src/application/SprintApplication.php b/src/application/SprintApplication.php
-index 7d429f20a268..b9b483cb1df1 100644
---- a/src/application/SprintApplication.php
-+++ b/src/application/SprintApplication.php
-@@ -41,28 +41,4 @@ final class SprintApplication extends PhabricatorApplication {
- );
- }
-
-- protected function getCustomCapabilities() {
-- return array(
-- SprintDefaultViewCapability::CAPABILITY => array(
-- 'caption' => pht(
-- 'Default view policy for newly created sprints.'),
-- ),
-- ProjectCreateProjectsCapability::CAPABILITY => array(),
-- ProjectCanLockProjectsCapability::CAPABILITY => array(
-- 'default' => PhabricatorPolicies::POLICY_ADMIN,
-- ),
-- ManiphestDefaultViewCapability::CAPABILITY => array(
-- 'caption' => pht('Default view policy for newly created tasks.'),
-- ),
-- ManiphestDefaultEditCapability::CAPABILITY => array(
-- 'caption' => pht('Default edit policy for newly created tasks.'),
-- ),
-- ManiphestEditStatusCapability::CAPABILITY => array(),
-- ManiphestEditAssignCapability::CAPABILITY => array(),
-- ManiphestEditPoliciesCapability::CAPABILITY => array(),
-- ManiphestEditPriorityCapability::CAPABILITY => array(),
-- ManiphestEditProjectsCapability::CAPABILITY => array(),
-- ManiphestBulkEditCapability::CAPABILITY => array(),
-- );
-- }
- }
diff --git a/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20180823.ebuild b/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20191219.ebuild
index cb3f94d8..2f8abc45 100644
--- a/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20180823.ebuild
+++ b/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20191219.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,7 @@ DESCRIPTION="Manage your tasks with Points in Phabricator"
HOMEPAGE="https://phabricator.wikimedia.org/diffusion/PHSP/"
EGIT_REPO_URI="https://phabricator.wikimedia.org/diffusion/PHSP/phabricator-sprint.git"
EGIT_BRANCH="wmf/stable"
-EGIT_COMMIT="9da8f6c3f27282aa10375bb97592cbe86db99d24"
+EGIT_COMMIT="7f34f377a425e0a53504355e991d9ccf4eb40de6"
LICENSE="GPL-3"
SLOT="stable"
@@ -26,8 +26,6 @@ src_prepare() {
git remote add origin "${EGIT_REPO_URI}"
git remote -v > "${S}/GIT_REMOTE_INFO"
- eapply "${FILESDIR}/${PV}-Remove-getCustomCapabilities.patch"
-
find -type f -name .gitignore -print0 \
| xargs -0 --no-run-if-empty -- \
rm
diff --git a/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-9999.ebuild b/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-9999.ebuild
index bfc3fba6..b3007827 100644
--- a/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-9999.ebuild
+++ b/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-9999.ebuild
@@ -74,3 +74,10 @@ src_install() {
dodoc README.md RELEASE_NOTES.md
}
+
+pkg_postinst () {
+ elog
+ elog "After the first installation, you need to run:"
+ elog " cd /path/to/phabricator/install"
+ elog " bin/config set load-libraries '{\"sprint\":\"${EROOT}usr/share/php/${PN}/src\"}'"
+}