summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-01-11 19:12:26 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-01-12 02:38:54 +0000
commit30d79d5f0af547f5fb1872869c6fc7a28b5f637b (patch)
tree363b72467e06a35711522ae6be5beb9472512788 /www-apps
parentwww-client/arcanist: version bump (diff)
downloadportage-30d79d5f0af547f5fb1872869c6fc7a28b5f637b.tar.xz
www-apps/phabricator: version bump
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phabricator/files/20191213-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch (renamed from www-apps/phabricator/files/20180824-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch)15
-rw-r--r--www-apps/phabricator/files/20191213-blacklists-for-registering-users.patch (renamed from www-apps/phabricator/files/20180824-blacklists-for-registering-users.patch)14
-rw-r--r--www-apps/phabricator/files/9999-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch15
-rw-r--r--www-apps/phabricator/files/9999-blacklists-for-registering-users.patch14
-rw-r--r--www-apps/phabricator/phabricator-20191213.ebuild (renamed from www-apps/phabricator/phabricator-20180824.ebuild)12
-rw-r--r--www-apps/phabricator/phabricator-9999.ebuild4
6 files changed, 36 insertions, 38 deletions
diff --git a/www-apps/phabricator/files/20180824-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch b/www-apps/phabricator/files/20191213-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch
index f9f2484d..6e4d0fc5 100644
--- a/www-apps/phabricator/files/20180824-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch
+++ b/www-apps/phabricator/files/20191213-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch
@@ -1,15 +1,15 @@
-From a9b7339856c1ba30e0381d7b628e69d5cfaff0ff Mon Sep 17 00:00:00 2001
+From 2185597e5573ce0ed3c087d6d3a553a64906a2a5 Mon Sep 17 00:00:00 2001
From: Bertrand Jacquin <bertrand@jacquin.bzh>
Date: Sat, 22 Feb 2014 18:31:14 +0100
Subject: [PATCH 1/2] MEDIUM: Get VERSION for files in
/usr/share/<PN>/GIT_COMMIT_INFO rather than from git
---
- .../PhabricatorConfigVersionController.php | 29 +++++++++++-----------
- 1 file changed, 15 insertions(+), 14 deletions(-)
+ .../PhabricatorConfigVersionController.php | 27 ++++++++++---------
+ 1 file changed, 14 insertions(+), 13 deletions(-)
diff --git a/src/applications/config/controller/PhabricatorConfigVersionController.php b/src/applications/config/controller/PhabricatorConfigVersionController.php
-index 8a87dec5cce6..f6a218cfc422 100644
+index 153d36306267..2d7dca672f8d 100644
--- a/src/applications/config/controller/PhabricatorConfigVersionController.php
+++ b/src/applications/config/controller/PhabricatorConfigVersionController.php
@@ -105,20 +105,21 @@ final class PhabricatorConfigVersionController
@@ -27,9 +27,6 @@ index 8a87dec5cce6..f6a218cfc422 100644
-
- $log_futures[$lib] = id(new ExecFuture('%C', $log_command))
- ->setCWD($root);
--
-- $remote_futures[$lib] = id(new ExecFuture('%C', $remote_command))
-- ->setCWD($root);
+ switch ($lib) {
+ case "phutil":
+ $_dir = "libphutil";
@@ -40,7 +37,9 @@ index 8a87dec5cce6..f6a218cfc422 100644
+ default:
+ $_dir = $lib;
+ }
-+
+
+- $remote_futures[$lib] = id(new ExecFuture('%C', $remote_command))
+- ->setCWD($root);
+ $log_futures[$lib] =
+ id(new ExecFuture('cat -- %s', "/usr/share/" . $_dir . "/GIT_COMMIT_INFO"));
+ $remote_futures[$lib] =
diff --git a/www-apps/phabricator/files/20180824-blacklists-for-registering-users.patch b/www-apps/phabricator/files/20191213-blacklists-for-registering-users.patch
index 88983ede..224d10d0 100644
--- a/www-apps/phabricator/files/20180824-blacklists-for-registering-users.patch
+++ b/www-apps/phabricator/files/20191213-blacklists-for-registering-users.patch
@@ -1,4 +1,4 @@
-From 3022c06ecbc4856859e68bf7c7f88a9fbc31ad0b Mon Sep 17 00:00:00 2001
+From 58299e88217d42213a9e133adebc1b80d7f33a71 Mon Sep 17 00:00:00 2001
From: Carsten Haitzler <raster@rasterman.com>
Date: Thu, 8 Feb 2018 18:29:06 +0900
Subject: [PATCH 2/2] blacklists for registering users
@@ -6,16 +6,16 @@ Subject: [PATCH 2/2] blacklists for registering users
i came up with this patch to allow phab to have email blacklists for
registering users... thanks to spam.
---
- .../PhabricatorAuthenticationConfigOptions.php | 7 ++++++-
- .../people/storage/PhabricatorUserEmail.php | 20 +++++++++++++++++---
+ ...PhabricatorAuthenticationConfigOptions.php | 7 ++++++-
+ .../people/storage/PhabricatorUserEmail.php | 20 ++++++++++++++++---
2 files changed, 23 insertions(+), 4 deletions(-)
diff --git a/src/applications/config/option/PhabricatorAuthenticationConfigOptions.php b/src/applications/config/option/PhabricatorAuthenticationConfigOptions.php
-index 2239d98858d3..beb719fd4a5c 100644
+index 8058ecafcb41..6fb37d05ff29 100644
--- a/src/applications/config/option/PhabricatorAuthenticationConfigOptions.php
+++ b/src/applications/config/option/PhabricatorAuthenticationConfigOptions.php
@@ -69,7 +69,12 @@ final class PhabricatorAuthenticationConfigOptions
- "it implies {{auth.require-email-verification}}.\n\n".
+ "it implies @{config:auth.require-email-verification}.\n\n".
"You should omit the `@` from domains. Note that the domain must ".
"match exactly. If you allow `yourcompany.com`, that permits ".
- "`joe@yourcompany.com` but rejects `joe@mail.yourcompany.com`."))
@@ -29,10 +29,10 @@ index 2239d98858d3..beb719fd4a5c 100644
"yourcompany.com\nmail.yourcompany.com",
pht('Valid Setting')),
diff --git a/src/applications/people/storage/PhabricatorUserEmail.php b/src/applications/people/storage/PhabricatorUserEmail.php
-index 42946015dee1..e116d5421697 100644
+index 4e43b2fb41bf..8ebdc2b16132 100644
--- a/src/applications/people/storage/PhabricatorUserEmail.php
+++ b/src/applications/people/storage/PhabricatorUserEmail.php
-@@ -110,15 +110,29 @@ final class PhabricatorUserEmail extends PhabricatorUserDAO {
+@@ -129,15 +129,29 @@ final class PhabricatorUserEmail
return false;
}
diff --git a/www-apps/phabricator/files/9999-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch b/www-apps/phabricator/files/9999-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch
index 66669688..c59063fd 100644
--- a/www-apps/phabricator/files/9999-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch
+++ b/www-apps/phabricator/files/9999-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch
@@ -1,15 +1,15 @@
-From 4c2cff6c02973fd8f100d5a852f26b49f8ab231d Mon Sep 17 00:00:00 2001
+From 9d51324eb75c1927db48b50a6bdb57c985dfba7e Mon Sep 17 00:00:00 2001
From: Bertrand Jacquin <bertrand@jacquin.bzh>
Date: Sat, 22 Feb 2014 18:31:14 +0100
Subject: [PATCH 1/2] MEDIUM: Get VERSION for files in
/usr/share/<PN>/GIT_COMMIT_INFO rather than from git
---
- .../PhabricatorConfigVersionController.php | 29 +++++++++++-----------
- 1 file changed, 15 insertions(+), 14 deletions(-)
+ .../PhabricatorConfigVersionController.php | 27 ++++++++++---------
+ 1 file changed, 14 insertions(+), 13 deletions(-)
diff --git a/src/applications/config/controller/PhabricatorConfigVersionController.php b/src/applications/config/controller/PhabricatorConfigVersionController.php
-index 8a87dec5cce6..f6a218cfc422 100644
+index 153d36306267..2d7dca672f8d 100644
--- a/src/applications/config/controller/PhabricatorConfigVersionController.php
+++ b/src/applications/config/controller/PhabricatorConfigVersionController.php
@@ -105,20 +105,21 @@ final class PhabricatorConfigVersionController
@@ -27,9 +27,6 @@ index 8a87dec5cce6..f6a218cfc422 100644
-
- $log_futures[$lib] = id(new ExecFuture('%C', $log_command))
- ->setCWD($root);
--
-- $remote_futures[$lib] = id(new ExecFuture('%C', $remote_command))
-- ->setCWD($root);
+ switch ($lib) {
+ case "phutil":
+ $_dir = "libphutil";
@@ -40,7 +37,9 @@ index 8a87dec5cce6..f6a218cfc422 100644
+ default:
+ $_dir = $lib;
+ }
-+
+
+- $remote_futures[$lib] = id(new ExecFuture('%C', $remote_command))
+- ->setCWD($root);
+ $log_futures[$lib] =
+ id(new ExecFuture('cat -- %s', "/usr/share/" . $_dir . "/GIT_COMMIT_INFO"));
+ $remote_futures[$lib] =
diff --git a/www-apps/phabricator/files/9999-blacklists-for-registering-users.patch b/www-apps/phabricator/files/9999-blacklists-for-registering-users.patch
index 045fb272..e177656a 100644
--- a/www-apps/phabricator/files/9999-blacklists-for-registering-users.patch
+++ b/www-apps/phabricator/files/9999-blacklists-for-registering-users.patch
@@ -1,4 +1,4 @@
-From 03e04ca72ff2aee58631d4901da796430a0c0704 Mon Sep 17 00:00:00 2001
+From c1208af71788295664b7d53ab808ba8e6a5072b3 Mon Sep 17 00:00:00 2001
From: Carsten Haitzler <raster@rasterman.com>
Date: Thu, 8 Feb 2018 18:29:06 +0900
Subject: [PATCH 2/2] blacklists for registering users
@@ -6,16 +6,16 @@ Subject: [PATCH 2/2] blacklists for registering users
i came up with this patch to allow phab to have email blacklists for
registering users... thanks to spam.
---
- .../PhabricatorAuthenticationConfigOptions.php | 7 ++++++-
- .../people/storage/PhabricatorUserEmail.php | 20 +++++++++++++++++---
+ ...PhabricatorAuthenticationConfigOptions.php | 7 ++++++-
+ .../people/storage/PhabricatorUserEmail.php | 20 ++++++++++++++++---
2 files changed, 23 insertions(+), 4 deletions(-)
diff --git a/src/applications/config/option/PhabricatorAuthenticationConfigOptions.php b/src/applications/config/option/PhabricatorAuthenticationConfigOptions.php
-index 2239d98858d3..beb719fd4a5c 100644
+index 8058ecafcb41..6fb37d05ff29 100644
--- a/src/applications/config/option/PhabricatorAuthenticationConfigOptions.php
+++ b/src/applications/config/option/PhabricatorAuthenticationConfigOptions.php
@@ -69,7 +69,12 @@ final class PhabricatorAuthenticationConfigOptions
- "it implies {{auth.require-email-verification}}.\n\n".
+ "it implies @{config:auth.require-email-verification}.\n\n".
"You should omit the `@` from domains. Note that the domain must ".
"match exactly. If you allow `yourcompany.com`, that permits ".
- "`joe@yourcompany.com` but rejects `joe@mail.yourcompany.com`."))
@@ -29,10 +29,10 @@ index 2239d98858d3..beb719fd4a5c 100644
"yourcompany.com\nmail.yourcompany.com",
pht('Valid Setting')),
diff --git a/src/applications/people/storage/PhabricatorUserEmail.php b/src/applications/people/storage/PhabricatorUserEmail.php
-index 42946015dee1..e116d5421697 100644
+index 4e43b2fb41bf..8ebdc2b16132 100644
--- a/src/applications/people/storage/PhabricatorUserEmail.php
+++ b/src/applications/people/storage/PhabricatorUserEmail.php
-@@ -110,15 +110,29 @@ final class PhabricatorUserEmail extends PhabricatorUserDAO {
+@@ -129,15 +129,29 @@ final class PhabricatorUserEmail
return false;
}
diff --git a/www-apps/phabricator/phabricator-20180824.ebuild b/www-apps/phabricator/phabricator-20191213.ebuild
index eb293d93..76222511 100644
--- a/www-apps/phabricator/phabricator-20180824.ebuild
+++ b/www-apps/phabricator/phabricator-20191213.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,7 @@ DESCRIPTION="Collection of web applications which makes it easier to scale softw
HOMEPAGE="https://www.phacility.com"
EGIT_REPO_URI="https://github.com/phacility/phabricator.git"
EGIT_BRANCH="stable"
-EGIT_COMMIT="fa4f53077172a865bfd89b6063807afe03bd722b"
+EGIT_COMMIT="c4b4a53cad7722f031b725f8b41511e9d341d033"
LICENSE="Apache-2.0"
SLOT="stable"
@@ -21,7 +21,7 @@ REQUIRED_USE="test? ( git mercurial subversion )"
DEPEND="!${CATEGORY}/${PN}:0
virtual/awk:0
test? (
- =www-client/arcanist-20180824:stable[test]
+ =www-client/arcanist-20191119:stable[test]
)"
RDEPEND=">=app-admin/webapp-config-1.51-r1:0
sys-apps/gentoo-functions
@@ -36,14 +36,14 @@ RDEPEND=">=app-admin/webapp-config-1.51-r1:0
dev-php/PHPExcel
media-gfx/imagemagick[jpeg,png,webp]
virtual/mysql
- =dev-php/libphutil-20180824:stable
+ =dev-php/libphutil-20190930:stable
net-libs/nodejs:0
- =www-client/arcanist-20180824:stable[git?,mercurial?,subversion?]
+ =www-client/arcanist-20191119:stable[git?,mercurial?,subversion?]
git? ( dev-vcs/git:0 )
mercurial? ( >dev-vcs/mercurial-2.2:0 )
subversion? ( >dev-vcs/subversion-1.7.1:0 )
highlight? ( dev-python/pygments:0 )
- mail? ( dev-php/pecl-mailparse:0 )"
+ mail? ( dev-php/pecl-mailparse:7 )"
PDEPEND="extension-sprint? ( www-apps/phabricator-extensions-Sprint )"
pkg_setup() {
diff --git a/www-apps/phabricator/phabricator-9999.ebuild b/www-apps/phabricator/phabricator-9999.ebuild
index bd4d7c94..c7bea6bd 100644
--- a/www-apps/phabricator/phabricator-9999.ebuild
+++ b/www-apps/phabricator/phabricator-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -41,7 +41,7 @@ RDEPEND=">=app-admin/webapp-config-1.51-r1:0
mercurial? ( >dev-vcs/mercurial-2.2:0 )
subversion? ( >dev-vcs/subversion-1.7.1:0 )
highlight? ( dev-python/pygments:0 )
- mail? ( dev-php/pecl-mailparse:0 )"
+ mail? ( dev-php/pecl-mailparse:7 )"
PDEPEND="extension-sprint? ( =www-apps/phabricator-extensions-Sprint-${PV} )"
pkg_setup() {