summaryrefslogtreecommitdiff
path: root/net-p2p/monero/files
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-03-19 18:05:58 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-03-19 19:49:15 +0000
commit999111573213f4702e9e832f74e4524d627312bf (patch)
tree3a76ce9d2d70f9f037f2181378ce8d92e1cba0b4 /net-p2p/monero/files
parentprofiles/common: enable bcrypt for sys-apps/shadow (diff)
downloadportage-999111573213f4702e9e832f74e4524d627312bf.tar.xz
net-p2p/monero: Version bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Diffstat (limited to 'net-p2p/monero/files')
-rw-r--r--net-p2p/monero/files/0.15.0.5-Do-not-install-trezor-dep-libs.patch25
-rw-r--r--net-p2p/monero/files/0.15.0.5-Drop-in-tree-miniupnpc.patch57
-rw-r--r--net-p2p/monero/files/0.15.0.5-Use-gentoo-dev-libs-randomx.patch18
-rw-r--r--net-p2p/monero/files/0.15.0.5-Use-gentoo-versioning.patch37
-rw-r--r--net-p2p/monero/files/0.15.0.5-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch46
-rw-r--r--net-p2p/monero/files/0.15.0.5-translations-use-host-compiler.patch30
6 files changed, 213 insertions, 0 deletions
diff --git a/net-p2p/monero/files/0.15.0.5-Do-not-install-trezor-dep-libs.patch b/net-p2p/monero/files/0.15.0.5-Do-not-install-trezor-dep-libs.patch
new file mode 100644
index 00000000..d268548c
--- /dev/null
+++ b/net-p2p/monero/files/0.15.0.5-Do-not-install-trezor-dep-libs.patch
@@ -0,0 +1,25 @@
+From fd666a409ceb0b8bf88e2e08255a4486a07bfb0f Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 15 Jun 2019 00:57:09 +0100
+Subject: [PATCH] Do not install trezor dep libs
+
+---
+ src/wallet/CMakeLists.txt | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
+index 3be1a6f6b2bf..8b0008fadf15 100644
+--- a/src/wallet/CMakeLists.txt
++++ b/src/wallet/CMakeLists.txt
+@@ -148,11 +148,7 @@ if (BUILD_GUI_DEPS)
+ install(TARGETS wallet_merged
+ ARCHIVE DESTINATION ${lib_folder})
+
+- install(FILES ${TREZOR_DEP_LIBS}
+- DESTINATION ${lib_folder})
+ file(WRITE "trezor_link_flags.txt" ${TREZOR_DEP_LINKER})
+- install(FILES "trezor_link_flags.txt"
+- DESTINATION ${lib_folder})
+ endif()
+
+ add_subdirectory(api)
diff --git a/net-p2p/monero/files/0.15.0.5-Drop-in-tree-miniupnpc.patch b/net-p2p/monero/files/0.15.0.5-Drop-in-tree-miniupnpc.patch
new file mode 100644
index 00000000..4dccd659
--- /dev/null
+++ b/net-p2p/monero/files/0.15.0.5-Drop-in-tree-miniupnpc.patch
@@ -0,0 +1,57 @@
+From 557cbfb6f4cdb5c491ac75ff4f5e05c4747d1f79 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sun, 17 Jun 2018 22:34:11 +0100
+Subject: [PATCH] Drop in-tree miniupnpc
+
+Since 6b8539803184 ("Build: update CMake and p2p for in-tree
+miniupnp"), a hard dependency is made on miniupnpc which is a git
+submodule not part of the archive available upstream.
+---
+ external/CMakeLists.txt | 16 +++-------------
+ src/p2p/net_node.inl | 6 +++---
+ 2 files changed, 6 insertions(+), 16 deletions(-)
+
+diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
+index 71b165f4f166..072a26d19586 100644
+--- a/external/CMakeLists.txt
++++ b/external/CMakeLists.txt
+@@ -37,19 +37,9 @@
+
+ find_package(Miniupnpc REQUIRED)
+
+-message(STATUS "Using in-tree miniupnpc")
+-add_subdirectory(miniupnp/miniupnpc)
+-set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
+-if(MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
+-elseif(NOT MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
+-endif()
+-if(CMAKE_SYSTEM_NAME MATCHES "NetBSD")
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -D_NETBSD_SOURCE")
+-endif()
+-
+-set(UPNP_LIBRARIES "libminiupnpc-static" PARENT_SCOPE)
++set(UPNP_STATIC false PARENT_SCOPE)
++set(UPNP_INCLUDE ${MINIUPNP_INCLUDE_DIR} PARENT_SCOPE)
++set(UPNP_LIBRARIES ${MINIUPNP_LIBRARY} PARENT_SCOPE)
+
+ find_package(Unbound)
+
+diff --git a/src/p2p/net_node.inl b/src/p2p/net_node.inl
+index 316ed1586e56..e33bac5175bd 100644
+--- a/src/p2p/net_node.inl
++++ b/src/p2p/net_node.inl
+@@ -60,9 +60,9 @@
+ #include "cryptonote_core/cryptonote_core.h"
+ #include "net/parse.h"
+
+-#include <miniupnp/miniupnpc/miniupnpc.h>
+-#include <miniupnp/miniupnpc/upnpcommands.h>
+-#include <miniupnp/miniupnpc/upnperrors.h>
++#include <miniupnpc/miniupnpc.h>
++#include <miniupnpc/upnpcommands.h>
++#include <miniupnpc/upnperrors.h>
+
+ #undef MONERO_DEFAULT_LOG_CATEGORY
+ #define MONERO_DEFAULT_LOG_CATEGORY "net.p2p"
diff --git a/net-p2p/monero/files/0.15.0.5-Use-gentoo-dev-libs-randomx.patch b/net-p2p/monero/files/0.15.0.5-Use-gentoo-dev-libs-randomx.patch
new file mode 100644
index 00000000..9c1b4307
--- /dev/null
+++ b/net-p2p/monero/files/0.15.0.5-Use-gentoo-dev-libs-randomx.patch
@@ -0,0 +1,18 @@
+From 13af354288a9334877ee4813eff3408a3af1c836 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Wed, 6 Nov 2019 01:23:52 +0000
+Subject: [PATCH] Use gentoo dev-libs/randomx
+
+---
+ external/CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
+index 072a26d19586..10189ce3a2fb 100644
+--- a/external/CMakeLists.txt
++++ b/external/CMakeLists.txt
+@@ -70,4 +70,3 @@ endif()
+
+ add_subdirectory(db_drivers)
+ add_subdirectory(easylogging++)
+-add_subdirectory(randomx EXCLUDE_FROM_ALL)
diff --git a/net-p2p/monero/files/0.15.0.5-Use-gentoo-versioning.patch b/net-p2p/monero/files/0.15.0.5-Use-gentoo-versioning.patch
new file mode 100644
index 00000000..18f6ef51
--- /dev/null
+++ b/net-p2p/monero/files/0.15.0.5-Use-gentoo-versioning.patch
@@ -0,0 +1,37 @@
+From 0afb322b7f23924fcf5469fa6a012fb161f3d048 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 15 Jun 2019 00:15:54 +0100
+Subject: [PATCH] Use gentoo versioning
+
+---
+ cmake/Version.cmake | 18 +++---------------
+ 1 file changed, 3 insertions(+), 15 deletions(-)
+
+diff --git a/cmake/Version.cmake b/cmake/Version.cmake
+index 26c2e2a1d447..d595b8293e1b 100644
+--- a/cmake/Version.cmake
++++ b/cmake/Version.cmake
+@@ -31,20 +31,8 @@ function (write_version tag)
+ configure_file("${CMAKE_SOURCE_DIR}/src/version.cpp.in" "${CMAKE_BINARY_DIR}/version.cpp")
+ endfunction ()
+
+-find_package(Git QUIET)
+-if ("$Format:$" STREQUAL "")
+- # We're in a tarball; use hard-coded variables.
+- set(VERSION_IS_RELEASE "true")
+- write_version("release")
+-elseif (GIT_FOUND OR Git_FOUND)
+- message(STATUS "Found Git: ${GIT_EXECUTABLE}")
+- include(GitVersion)
+- get_version_tag_from_git("${GIT_EXECUTABLE}")
+- write_version("${VERSIONTAG}")
+-else()
+- message(STATUS "WARNING: Git was not found!")
+- set(VERSION_IS_RELEASE "false")
+- write_version("unknown")
+-endif ()
++set(VERSION_IS_RELEASE "true")
++write_version("release")
++
+ add_custom_target(genversion ALL
+ DEPENDS "${CMAKE_BINARY_DIR}/version.cpp")
diff --git a/net-p2p/monero/files/0.15.0.5-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch b/net-p2p/monero/files/0.15.0.5-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch
new file mode 100644
index 00000000..d3e075ac
--- /dev/null
+++ b/net-p2p/monero/files/0.15.0.5-https-sourceware.org-bugzilla-show_bug.cgi-id-25210.patch
@@ -0,0 +1,46 @@
+From febacda6465ec02768989cd4c49fe7f062867a2f Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 30 Nov 2019 03:25:11 +0000
+Subject: [PATCH] https://sourceware.org/bugzilla/show_bug.cgi?id=25210
+
+---
+ CMakeLists.txt | 19 -------------------
+ 1 file changed, 19 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 03e60cb1a475..cbf7232bd57b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -714,11 +714,6 @@ else()
+ CHECK_CXX_ACCEPTS_FLAG(-mfloat-abi=softfp CXX_ACCEPTS_MFLOAT_SOFTFP)
+ endif()
+
+- if(ARM8)
+- CHECK_CXX_ACCEPTS_FLAG(-mfix-cortex-a53-835769 CXX_ACCEPTS_MFIX_CORTEX_A53_835769)
+- CHECK_CXX_ACCEPTS_FLAG(-mfix-cortex-a53-843419 CXX_ACCEPTS_MFIX_CORTEX_A53_843419)
+- endif()
+-
+ if(ARM6)
+ message(STATUS "Selecting VFP for ARMv6")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfpu=vfp")
+@@ -755,20 +750,6 @@ else()
+ endif()
+ endif(ARM7)
+
+- if(ARM8)
+- if(CXX_ACCEPTS_MFIX_CORTEX_A53_835769)
+- message(STATUS "Enabling Cortex-A53 workaround 835769")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfix-cortex-a53-835769")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfix-cortex-a53-835769")
+- endif()
+-
+- if(CXX_ACCEPTS_MFIX_CORTEX_A53_843419)
+- message(STATUS "Enabling Cortex-A53 workaround 843419")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfix-cortex-a53-843419")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfix-cortex-a53-843419")
+- endif()
+- endif(ARM8)
+-
+ endif(ARM)
+
+ if(ANDROID AND NOT BUILD_GUI_DEPS STREQUAL "ON" OR IOS)
diff --git a/net-p2p/monero/files/0.15.0.5-translations-use-host-compiler.patch b/net-p2p/monero/files/0.15.0.5-translations-use-host-compiler.patch
new file mode 100644
index 00000000..4f36ec1f
--- /dev/null
+++ b/net-p2p/monero/files/0.15.0.5-translations-use-host-compiler.patch
@@ -0,0 +1,30 @@
+From 759970067c04bab479f9a923cfa593adfe0c87f2 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 30 Nov 2019 02:09:14 +0000
+Subject: [PATCH] translations: use host compiler
+
+Do not pass target compiler and compiler flags as
+generate_translations_header need to be created using host compiler and
+compiler flags
+---
+ CMakeLists.txt | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 03ede04837b5..03e60cb1a475 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -451,7 +451,12 @@ ExternalProject_Add(generate_translations_header
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
+ BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
+ STAMP_DIR ${LRELEASE_PATH}
+- CMAKE_ARGS -DLRELEASE_PATH=${LRELEASE_PATH}
++ CMAKE_ARGS
++ -DCMAKE_C_COMPILER=$ENV{BUILD_CC}
++ -DCMAKE_CXX_COMPILER=$ENV{BUILD_CXX}
++ -DCMAKE_C_FLAGS=$ENV{BUILD_CFLAGS}
++ -DCMAKE_CXX_FLAGS=$ENV{BUILD_CXXFLAGS}
++ -DLRELEASE_PATH=${LRELEASE_PATH}
+ INSTALL_COMMAND cmake -E echo "")
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
+ add_subdirectory(external)