summaryrefslogtreecommitdiff
path: root/net-p2p/monero/files/0.15.0.5-translations-use-host-compiler.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/monero/files/0.15.0.5-translations-use-host-compiler.patch')
-rw-r--r--net-p2p/monero/files/0.15.0.5-translations-use-host-compiler.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-p2p/monero/files/0.15.0.5-translations-use-host-compiler.patch b/net-p2p/monero/files/0.15.0.5-translations-use-host-compiler.patch
new file mode 100644
index 00000000..4f36ec1f
--- /dev/null
+++ b/net-p2p/monero/files/0.15.0.5-translations-use-host-compiler.patch
@@ -0,0 +1,30 @@
+From 759970067c04bab479f9a923cfa593adfe0c87f2 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 30 Nov 2019 02:09:14 +0000
+Subject: [PATCH] translations: use host compiler
+
+Do not pass target compiler and compiler flags as
+generate_translations_header need to be created using host compiler and
+compiler flags
+---
+ CMakeLists.txt | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 03ede04837b5..03e60cb1a475 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -451,7 +451,12 @@ ExternalProject_Add(generate_translations_header
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
+ BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
+ STAMP_DIR ${LRELEASE_PATH}
+- CMAKE_ARGS -DLRELEASE_PATH=${LRELEASE_PATH}
++ CMAKE_ARGS
++ -DCMAKE_C_COMPILER=$ENV{BUILD_CC}
++ -DCMAKE_CXX_COMPILER=$ENV{BUILD_CXX}
++ -DCMAKE_C_FLAGS=$ENV{BUILD_CFLAGS}
++ -DCMAKE_CXX_FLAGS=$ENV{BUILD_CXXFLAGS}
++ -DLRELEASE_PATH=${LRELEASE_PATH}
+ INSTALL_COMMAND cmake -E echo "")
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
+ add_subdirectory(external)