summaryrefslogtreecommitdiff
path: root/media-tv
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2022-11-30 20:44:27 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2022-11-30 20:44:27 +0000
commitd91747cc71ef268cad7dc168298c67ed2f46d08b (patch)
treed436d4d69466144bd85a3c757d508bc4cd0e76cd /media-tv
parentdev-util/cpplint: enable python3.11 (diff)
downloadportage-d91747cc71ef268cad7dc168298c67ed2f46d08b.tar.xz
media-tv/congruity: enable py3.10 and disable py3.8
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/congruity/congruity-20.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-tv/congruity/congruity-20.ebuild b/media-tv/congruity/congruity-20.ebuild
index e7e1b264..8fd3fe33 100644
--- a/media-tv/congruity/congruity-20.ebuild
+++ b/media-tv/congruity/congruity-20.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
inherit distutils-r1 xdg-utils
DESCRIPTION="GUI application for programming Logitech Harmony"
@@ -18,7 +20,7 @@ DEPEND="
dev-python/wxpython:4.0[${PYTHON_USEDEP}]
>=dev-libs/libconcord-1.3[python,${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/suds-0.7[${PYTHON_USEDEP}]
+ >=dev-python/suds-community-0.7[${PYTHON_USEDEP}]
app-crypt/libsecret
dev-python/pygobject:3[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"