summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-tv/congruity/congruity-20.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-tv/congruity/congruity-20.ebuild b/media-tv/congruity/congruity-20.ebuild
index e7e1b264..8fd3fe33 100644
--- a/media-tv/congruity/congruity-20.ebuild
+++ b/media-tv/congruity/congruity-20.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
inherit distutils-r1 xdg-utils
DESCRIPTION="GUI application for programming Logitech Harmony"
@@ -18,7 +20,7 @@ DEPEND="
dev-python/wxpython:4.0[${PYTHON_USEDEP}]
>=dev-libs/libconcord-1.3[python,${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/suds-0.7[${PYTHON_USEDEP}]
+ >=dev-python/suds-community-0.7[${PYTHON_USEDEP}]
app-crypt/libsecret
dev-python/pygobject:3[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"