summaryrefslogtreecommitdiff
path: root/flx
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-09-26 17:33:18 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 01:19:03 +0100
commitfea57a12c8b3ac86eb3b562ad9711e6696809f75 (patch)
tree9bd7ba2603923d7a343068c21ab371ead750d4ea /flx
parentflx/preinit: move to EAPI 7 (diff)
downloadportage-fea57a12c8b3ac86eb3b562ad9711e6696809f75.tar.xz
flx/remount: move to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Diffstat (limited to 'flx')
-rw-r--r--flx/remount/remount-0.1.35.ebuild12
-rw-r--r--flx/remount/remount-9999.ebuild12
2 files changed, 14 insertions, 10 deletions
diff --git a/flx/remount/remount-0.1.35.ebuild b/flx/remount/remount-0.1.35.ebuild
index 8c650424..edf3ae73 100644
--- a/flx/remount/remount-0.1.35.ebuild
+++ b/flx/remount/remount-0.1.35.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 toolchain-funcs eutils
DESCRIPTION="Formilux Tools"
@@ -14,12 +14,14 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+PATCHES=(
+ "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
+ "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
+)
+
src_prepare () {
default
- eapply "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
- eapply "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
-
tc-export CC
}
diff --git a/flx/remount/remount-9999.ebuild b/flx/remount/remount-9999.ebuild
index f91bdcca..7e8c4988 100644
--- a/flx/remount/remount-9999.ebuild
+++ b/flx/remount/remount-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 toolchain-funcs eutils
DESCRIPTION="Formilux Tools"
@@ -13,12 +13,14 @@ SLOT="0"
KEYWORDS=""
IUSE=""
+PATCHES=(
+ "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
+ "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
+)
+
src_prepare () {
default
- eapply "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
- eapply "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
-
tc-export CC
}