summaryrefslogtreecommitdiff
path: root/flx
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-09-26 17:05:08 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 01:19:00 +0100
commitb63fd60004709badd0f8049fb6aad4355c76da76 (patch)
tree1db8b9c4e99aed6fe1912ddcd46acca2b1ca17f9 /flx
parentflx/wdd: move to EAPI 7 (diff)
downloadportage-b63fd60004709badd0f8049fb6aad4355c76da76.tar.xz
flx/dfc: move to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Diffstat (limited to 'flx')
-rw-r--r--flx/dfc/dfc-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/flx/dfc/dfc-9999.ebuild b/flx/dfc/dfc-9999.ebuild
index 086ec4f0..8b55ae68 100644
--- a/flx/dfc/dfc-9999.ebuild
+++ b/flx/dfc/dfc-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 toolchain-funcs eutils
DESCRIPTION="Formilux Tools"
@@ -12,20 +12,19 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
+ "${FILESDIR}/${PV}-warning-cast.diff"
+ "${FILESDIR}/${PV}-BUG-MAJOR-Do-not-inline-pferror.patch"
+)
src_prepare () {
default
- eapply "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
- eapply "${FILESDIR}/${PV}-warning-cast.diff"
- eapply "${FILESDIR}/${PV}-BUG-MAJOR-Do-not-inline-pferror.patch"
-
tc-export CC
}
src_install () {
into /usr
- dobin dfc
+ dobin "${PN}"
}