summaryrefslogtreecommitdiff
path: root/flx
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-09-26 17:04:05 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 01:19:00 +0100
commit8932a052d5f0f5798abcfe647802b446bd9c0bbf (patch)
tree3d1de9fcc27ec7c0d37cb267caf75a300476d64e /flx
parentflx/init-vixie-cron: drop old (diff)
downloadportage-8932a052d5f0f5798abcfe647802b446bd9c0bbf.tar.xz
flx/wdd: move to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Diffstat (limited to 'flx')
-rw-r--r--flx/wdd/files/0.1.35-MEDIUM-Remove-strip-and-uclibc.patch149
-rw-r--r--flx/wdd/files/0.1.35-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch56
-rw-r--r--flx/wdd/wdd-0.1.35.ebuild37
-rw-r--r--flx/wdd/wdd-0.1.36.ebuild16
-rw-r--r--flx/wdd/wdd-9999.ebuild16
5 files changed, 18 insertions, 256 deletions
diff --git a/flx/wdd/files/0.1.35-MEDIUM-Remove-strip-and-uclibc.patch b/flx/wdd/files/0.1.35-MEDIUM-Remove-strip-and-uclibc.patch
deleted file mode 100644
index 6ffe6b44..00000000
--- a/flx/wdd/files/0.1.35-MEDIUM-Remove-strip-and-uclibc.patch
+++ /dev/null
@@ -1,149 +0,0 @@
-From caa62e8ba16c340aafd45375ec99f48261e62abf Mon Sep 17 00:00:00 2001
-From: Bertrand Jacquin <bertrand@jacquin.bzh>
-Date: Mon, 27 May 2013 22:36:39 +0200
-Subject: [PATCH 1/2] MEDIUM: Remove strip and uclibc
-
----
- flx/Makefile | 1 -
- ifenslave/Makefile | 3 ---
- include/rules.make | 16 +---------------
- lcd/Makefile | 3 ---
- mii/Makefile | 3 ---
- mktmp/Makefile | 3 ---
- remount/Makefile | 3 ---
- signfs/Makefile | 1 -
- wd/Makefile | 3 ---
- 9 files changed, 1 insertion(+), 35 deletions(-)
-
-diff --git a/flx/Makefile b/flx/Makefile
-index 68ecb4c..408c9b5 100644
---- a/flx/Makefile
-+++ b/flx/Makefile
-@@ -39,7 +39,6 @@ all: $(NAME)
-
- $(NAME): $(OBJ)
- $(CC) -o $(NAME) $(OBJ) $(LDFLAGS)
--# strip -R .note -R .comment signfs
-
- clean:
- @$(RM) -vf $(NAME) $(OBJ) $(LIBTOOLS:.c=.o) *~ core *.bak
-diff --git a/ifenslave/Makefile b/ifenslave/Makefile
-index 7ba3dc7..14fd640 100644
---- a/ifenslave/Makefile
-+++ b/ifenslave/Makefile
-@@ -13,9 +13,6 @@ ifenslave:
-
- ifenslave%: ifenslave%.o
- $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $<
-- $(STRIP) -x --strip-unneeded -R .comment -R .note $@
-- $(OBJDUMP) -h $@ | grep -q '\.data[ ]*00000000' && $(STRIP) -R .data $@ || true
-- # sstrip $@
-
- %.o: %.c
- $(CC) $(CFLAGS) -c -o $@ $<
-diff --git a/include/rules.make b/include/rules.make
-index 715db29..f373aad 100644
---- a/include/rules.make
-+++ b/include/rules.make
-@@ -1,30 +1,16 @@
- CC ?= gcc
--STRIP ?= strip
--OBJDUMP ?= objdump
--SSTRIP ?= sstrip
--UCLIBC ?= uclibc
--
--CC_ORIG := $(CC)
--override CC := $(UCLIBC) $(CC) -Os
-
- CFLAGS=$(GCC_ARCH_SMALL) $(GCC_CPU_SMALL) $(GCC_OPT_SMALL)
- #-mpreferred-stack-boundary=2 -malign-jumps=0 -malign-loops=0 -malign-functions=0 -Os -march=i386 -mcpu=i386
--LDFLAGS=-s -Wl,--gc-sections
-+LDFLAGS=-Wl,--gc-sections
-
- all: $(OBJS)
-
- %: %.c
- $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $<
-- $(STRIP) -x --strip-unneeded -R .comment -R .note $@
-- $(OBJDUMP) -h $@ | grep -q '\.data[ ]*00000000' && $(STRIP) -R .data $@ || true
-- $(OBJDUMP) -h $@ | grep -q '\.sbss[ ]*00000000' && $(STRIP) -R .sbss $@ || true
-- #-if [ -n "$(SSTRIP)" ]; then $(SSTRIP) $@ ; fi
-
- %-debug: %.c
- $(CC) $(LDFLAGS) $(CFLAGS) -DDEBUG -o $@ $<
-- $(STRIP) -x --strip-unneeded -R .comment -R .note $@
-- $(OBJDUMP) -h $@ | grep -q '\.data[ ]*00000000' && $(STRIP) -R .data $@ || true
-- $(OBJDUMP) -h $@ | grep -q '\.sbss[ ]*00000000' && $(STRIP) -R .sbss $@ || true
-
- clean:
- @rm -f *.[ao] *~ core
-diff --git a/lcd/Makefile b/lcd/Makefile
-index 71d861f..4de920f 100644
---- a/lcd/Makefile
-+++ b/lcd/Makefile
-@@ -4,6 +4,3 @@ CFLAGS+=-fomit-frame-pointer
-
- %: %.c
- $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $<
-- $(STRIP) -x --strip-unneeded -R .comment -R .note $@
-- $(OBJDUMP) -h $@ | grep -q '\.data[ ]*00000000' && $(STRIP) -R .data $@ || true
-- #$(SSTRIP) $@
-diff --git a/mii/Makefile b/mii/Makefile
-index 791f6b9..21d64d3 100644
---- a/mii/Makefile
-+++ b/mii/Makefile
-@@ -7,9 +7,6 @@ all: $(OBJS)
-
- %-diag: %-diag.o libmii.o
- $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $^
-- $(STRIP) -x --strip-unneeded -R .comment -R .note $@
-- $(OBJDUMP) -h $@ | grep -q '\.data[ ]*00000000' && $(STRIP) -R .data $@ || true
-- #$(SSTRIP) $@
-
- %.o: %.c
- $(CC) -DLIBMII $(CFLAGS) -c -o $@ $<
-diff --git a/mktmp/Makefile b/mktmp/Makefile
-index 2188b91..ef4b083 100644
---- a/mktmp/Makefile
-+++ b/mktmp/Makefile
-@@ -4,6 +4,3 @@ include ../include/rules.make
-
- %: %.c
- $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $<
-- $(STRIP) -x --strip-unneeded -R .comment -R .note $@
-- $(OBJDUMP) -h $@ | grep -q '\.data[ ]*00000000' && $(STRIP) -R .data $@ || true
-- #$(SSTRIP) $@
-diff --git a/remount/Makefile b/remount/Makefile
-index 5aa2491..54a79ad 100644
---- a/remount/Makefile
-+++ b/remount/Makefile
-@@ -7,6 +7,3 @@ remountw : remountr
-
- %: %.c
- $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $<
-- $(STRIP) -x --strip-unneeded -R .comment -R .note $@
-- $(OBJDUMP) -h $@ | grep -q '\.data[ ]*00000000' && $(STRIP) -R .data $@ || true
-- -if [ -n "$(SSTRIP)" ]; then $(SSTRIP) $@ ; fi
-diff --git a/signfs/Makefile b/signfs/Makefile
-index f50b301..d4214c6 100644
---- a/signfs/Makefile
-+++ b/signfs/Makefile
-@@ -35,7 +35,6 @@ LIBTOOLS=md5.c libtools.c others.c
-
- $(NAME): libtools.a $(OBJ)
- $(CC) -o $(NAME) $(OBJ) $(LDFLAGS)
-- #strip -R .note -R .comment signfs
-
- libtools.a: $(LIBTOOLS:.c=.o)
- $(AR) -r libtools.a $(LIBTOOLS:.c=.o)
-diff --git a/wd/Makefile b/wd/Makefile
-index 6f1fa72..eaf857a 100644
---- a/wd/Makefile
-+++ b/wd/Makefile
-@@ -4,6 +4,3 @@ CFLAGS+=-fomit-frame-pointer
-
- %: %.c
- $(CC) $(LDFLAGS) $(CFLAGS) -W -Wall -U_FORTIFY_SOURCE -o $@ $<
-- $(STRIP) -x --strip-unneeded -R .comment -R .note $@
-- $(OBJDUMP) -h $@ | grep -q '\.data[ ]*00000000' && $(STRIP) -R .data $@ || true
-- -if [ -n "$(SSTRIP)" ]; then $(SSTRIP) $@ ; fi
diff --git a/flx/wdd/files/0.1.35-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch b/flx/wdd/files/0.1.35-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch
deleted file mode 100644
index dec2fc8d..00000000
--- a/flx/wdd/files/0.1.35-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 25a9b5d4cd1b57c81e697ff7e54bf9121e8bbfa4 Mon Sep 17 00:00:00 2001
-From: Bertrand Jacquin <bertrand@jacquin.bzh>
-Date: Mon, 27 May 2013 22:36:39 +0200
-Subject: [PATCH 2/2] MEDIUM: Respect CFLAGS and LDFLAGS
-
----
- flx/Makefile | 4 ++--
- include/rules.make | 5 ++---
- signfs/Makefile | 4 ++--
- 3 files changed, 6 insertions(+), 7 deletions(-)
-
-diff --git a/flx/Makefile b/flx/Makefile
-index 408c9b5..09e25b4 100644
---- a/flx/Makefile
-+++ b/flx/Makefile
-@@ -32,8 +32,8 @@ SRC=main.c arg.c utils.c md5.c flx.c fct1.c check.c sign.c \
- output.c output_file.c
- OBJ=$(SRC:.c=.o)
- COPTS=-O2 -fno-strict-aliasing
--CFLAGS= -Wall $(COPTS) -DMEM_OPTIM -DPROGRAM_NAME=\"$(NAME)\" -DPROGRAM_VERSION=\"$(VERSION)\" -U_FORTIFY_SOURCE
--LDFLAGS=-L. -Wl,--gc-sections
-+CFLAGS += -DMEM_OPTIM -DPROGRAM_NAME=\"$(NAME)\" -DPROGRAM_VERSION=\"$(VERSION)\" -U_FORTIFY_SOURCE
-+LDFLAGS += -L. -Wl,--gc-sections
-
- all: $(NAME)
-
-diff --git a/include/rules.make b/include/rules.make
-index f373aad..02240e0 100644
---- a/include/rules.make
-+++ b/include/rules.make
-@@ -1,8 +1,7 @@
- CC ?= gcc
-
--CFLAGS=$(GCC_ARCH_SMALL) $(GCC_CPU_SMALL) $(GCC_OPT_SMALL)
--#-mpreferred-stack-boundary=2 -malign-jumps=0 -malign-loops=0 -malign-functions=0 -Os -march=i386 -mcpu=i386
--LDFLAGS=-Wl,--gc-sections
-+CFLAGS += $(GCC_ARCH_SMALL) $(GCC_CPU_SMALL) $(GCC_OPT_SMALL)
-+LDFLAGS += -Wl,--gc-sections
-
- all: $(OBJS)
-
-diff --git a/signfs/Makefile b/signfs/Makefile
-index d4214c6..ab03992 100644
---- a/signfs/Makefile
-+++ b/signfs/Makefile
-@@ -29,8 +29,8 @@ NAME=signfs
- SRC=main.c signfs.c structure.c
- OBJ=$(SRC:.c=.o)
- COPTS=-Os -march=i386
--CFLAGS=$(COPTS) -Wall
--LDFLAGS=-L. -ltools
-+CFLAGS += -Wall
-+LDFLAGS += -L. -ltools
- LIBTOOLS=md5.c libtools.c others.c
-
- $(NAME): libtools.a $(OBJ)
diff --git a/flx/wdd/wdd-0.1.35.ebuild b/flx/wdd/wdd-0.1.35.ebuild
deleted file mode 100644
index 43471c06..00000000
--- a/flx/wdd/wdd-0.1.35.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit git-r3 eutils
-
-DESCRIPTION="Formilux Tools"
-HOMEPAGE="http://git.formilux.org/?p=dist/src/flxutils.git"
-EGIT_REPO_URI="http://master.formilux.org/git/dist/src/flxutils.git"
-EGIT_COMMIT="v${PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm mips x86"
-IUSE=""
-
-src_prepare () {
- default
-
- eapply "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
- eapply "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
-
- tc-export CC
-}
-
-src_compile () {
- emake -C wd
-}
-
-src_install () {
- into /
- dosbin wd/wdd
- doman wd/wdd.8
-
- newinitd "${FILESDIR}/wdd.initd" "${PN}"
- newconfd "${FILESDIR}/wdd.confd" "${PN}"
-}
diff --git a/flx/wdd/wdd-0.1.36.ebuild b/flx/wdd/wdd-0.1.36.ebuild
index fae1db47..3b4ded67 100644
--- a/flx/wdd/wdd-0.1.36.ebuild
+++ b/flx/wdd/wdd-0.1.36.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 eutils systemd
DESCRIPTION="Simple Watchdog Daemon"
@@ -14,12 +14,14 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 mips x86"
IUSE=""
+PATCHES=(
+ "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
+ "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
+)
+
src_prepare () {
default
- eapply "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
- eapply "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
-
tc-export CC
}
@@ -29,8 +31,8 @@ src_compile () {
src_install () {
into /
- dosbin wd/wdd
- doman wd/wdd.8
+ dosbin "wd/${PN}"
+ doman "wd/${PN}.8"
newinitd "${FILESDIR}/${PN}.initd" "${PN}"
newconfd "${FILESDIR}/${PN}.confd" "${PN}"
diff --git a/flx/wdd/wdd-9999.ebuild b/flx/wdd/wdd-9999.ebuild
index 4398fbb6..4d14245e 100644
--- a/flx/wdd/wdd-9999.ebuild
+++ b/flx/wdd/wdd-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 eutils
DESCRIPTION="Simple Watchdog Daemon"
@@ -13,12 +13,14 @@ SLOT="0"
KEYWORDS=""
IUSE=""
+PATCHES=(
+ "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
+ "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
+)
+
src_prepare () {
default
- eapply "${FILESDIR}/${PV}-MEDIUM-Remove-strip-and-uclibc.patch"
- eapply "${FILESDIR}/${PV}-MEDIUM-Respect-CFLAGS-and-LDFLAGS.patch"
-
tc-export CC
}
@@ -28,8 +30,8 @@ src_compile () {
src_install () {
into /
- dosbin wd/wdd
- doman wd/wdd.8
+ dosbin "wd/${PN}"
+ doman "wd/${PN}.8"
newinitd "${FILESDIR}/wdd.initd" "${PN}"
newconfd "${FILESDIR}/wdd.confd" "${PN}"