summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2019-06-17 23:52:15 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2019-06-17 23:52:31 +0100
commit563d04a108a8ff350b1273e7351eb43afee0dde9 (patch)
tree3d5ef22d0f2dbf0ac346c28877adb335f2a4165c /dev-python
parentdev-python/typing-extensions: Experimental types for dev-python/typing (diff)
downloadportage-563d04a108a8ff350b1273e7351eb43afee0dde9.tar.xz
dev-python/trezor: Python client for communicating with TREZOR
Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trezor/Manifest1
-rw-r--r--dev-python/trezor/metadata.xml8
-rw-r--r--dev-python/trezor/trezor-0.11.3.ebuild35
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/trezor/Manifest b/dev-python/trezor/Manifest
new file mode 100644
index 00000000..00d9239f
--- /dev/null
+++ b/dev-python/trezor/Manifest
@@ -0,0 +1 @@
+DIST trezor-0.11.3.tar.gz 5656969 BLAKE2B 745ce6b58d9adb612f8a8b5e55435ffa98bc6acf7b6e0e5437dfc24df284c1ef801dc57d0ec443fc118cde40cfaa652fc8c5632c6d5b2f3518a51fcb93fd4e44 SHA512 95a96704212af7191ed3fb43666122edd1a49bd3f3f9ea95b72051217bc5e25d4ad148228f607bc15875814e6d17a6b92fc550ea0770a1860eb2d9bd7fbce976
diff --git a/dev-python/trezor/metadata.xml b/dev-python/trezor/metadata.xml
new file mode 100644
index 00000000..82f7232e
--- /dev/null
+++ b/dev-python/trezor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/trezor/trezor-0.11.3.ebuild b/dev-python/trezor/trezor-0.11.3.ebuild
new file mode 100644
index 00000000..1a668e57
--- /dev/null
+++ b/dev-python/trezor/trezor-0.11.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+inherit distutils-r1 bash-completion-r1
+
+DESCRIPTION="Python client for communicating with TREZOR Hardware Wallet"
+HOMEPAGE="https://trezor.io"
+SRC_URI="https://github.com/trezor/trezor-firmware/archive/python/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-python/ecdsa-0.9[${PYTHON_USEDEP}]
+ >=dev-python/mnemonic-0.17[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7[${PYTHON_USEDEP}]
+ >=dev-python/pyblake2-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/libusb1-1.6.4[${PYTHON_USEDEP}]
+ >=dev-python/construct-2.9[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.6[${PYTHON_USEDEP}]
+ >=dev-python/hidapi-0.7.99_p20[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/trezor-firmware-python-v${PV}/python"
+
+python_install_all() {
+ newbashcomp bash_completion.d/trezorctl.sh trezorctl
+ distutils-r1_python_install_all
+}