summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/trezorctl/Manifest1
-rw-r--r--app-crypt/trezorctl/trezorctl-0.10.2.ebuild32
-rw-r--r--dev-python/trezor/Manifest1
-rw-r--r--dev-python/trezor/metadata.xml (renamed from app-crypt/trezorctl/metadata.xml)0
-rw-r--r--dev-python/trezor/trezor-0.11.3.ebuild35
5 files changed, 36 insertions, 33 deletions
diff --git a/app-crypt/trezorctl/Manifest b/app-crypt/trezorctl/Manifest
deleted file mode 100644
index dbdd531b..00000000
--- a/app-crypt/trezorctl/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST trezorctl-0.10.2.tar.gz 254192 BLAKE2B 39d1d282178a8e85d1f28b7c76a35919b9500ec9e4cacc80e5becb226f9f36207fbc22eb4ef85b95ba13d8518278a72a4013e8a16aecd98d29858b2fbef13915 SHA512 ec73c2ab75ddbff85fea014a5ad2988b8417fecc28188d33b4f66a444920e88f3f64e7b1973ac149c51545120da8b3acc1890626178372302ea2133f922f349c
diff --git a/app-crypt/trezorctl/trezorctl-0.10.2.ebuild b/app-crypt/trezorctl/trezorctl-0.10.2.ebuild
deleted file mode 100644
index e4afedbe..00000000
--- a/app-crypt/trezorctl/trezorctl-0.10.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
-inherit distutils-r1 bash-completion-r1
-
-DESCRIPTION="Client side implementation for TREZOR-compatible Bitcoin hardware wallets"
-HOMEPAGE="https://trezor.io/"
-SRC_URI="https://github.com/trezor/python-trezor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND=">=dev-python/ecdsa-0.9[${PYTHON_USEDEP}]
- >=dev-python/mnemonic-0.17[${PYTHON_USEDEP}]
- >=dev-python/hidapi-0.7.99_p20[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/click-6.2[${PYTHON_USEDEP}]
- >=dev-python/pyblake2-0.9.3[${PYTHON_USEDEP}]
- >=dev-python/libusb1-1.6.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/python-trezor-${PV}"
-
-python_install_all() {
- newbashcomp bash_completion.d/trezorctl.sh "${PN}"
- distutils-r1_python_install_all
-}
diff --git a/dev-python/trezor/Manifest b/dev-python/trezor/Manifest
new file mode 100644
index 00000000..00d9239f
--- /dev/null
+++ b/dev-python/trezor/Manifest
@@ -0,0 +1 @@
+DIST trezor-0.11.3.tar.gz 5656969 BLAKE2B 745ce6b58d9adb612f8a8b5e55435ffa98bc6acf7b6e0e5437dfc24df284c1ef801dc57d0ec443fc118cde40cfaa652fc8c5632c6d5b2f3518a51fcb93fd4e44 SHA512 95a96704212af7191ed3fb43666122edd1a49bd3f3f9ea95b72051217bc5e25d4ad148228f607bc15875814e6d17a6b92fc550ea0770a1860eb2d9bd7fbce976
diff --git a/app-crypt/trezorctl/metadata.xml b/dev-python/trezor/metadata.xml
index 82f7232e..82f7232e 100644
--- a/app-crypt/trezorctl/metadata.xml
+++ b/dev-python/trezor/metadata.xml
diff --git a/dev-python/trezor/trezor-0.11.3.ebuild b/dev-python/trezor/trezor-0.11.3.ebuild
new file mode 100644
index 00000000..1a668e57
--- /dev/null
+++ b/dev-python/trezor/trezor-0.11.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+inherit distutils-r1 bash-completion-r1
+
+DESCRIPTION="Python client for communicating with TREZOR Hardware Wallet"
+HOMEPAGE="https://trezor.io"
+SRC_URI="https://github.com/trezor/trezor-firmware/archive/python/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-python/ecdsa-0.9[${PYTHON_USEDEP}]
+ >=dev-python/mnemonic-0.17[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7[${PYTHON_USEDEP}]
+ >=dev-python/pyblake2-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/libusb1-1.6.4[${PYTHON_USEDEP}]
+ >=dev-python/construct-2.9[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.6[${PYTHON_USEDEP}]
+ >=dev-python/hidapi-0.7.99_p20[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/trezor-firmware-python-v${PV}/python"
+
+python_install_all() {
+ newbashcomp bash_completion.d/trezorctl.sh trezorctl
+ distutils-r1_python_install_all
+}