summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2011-07-26 20:14:59 +0200
committerBertrand Jacquin <beber@meleeweb.net>2011-07-26 20:14:59 +0200
commit2b390cfd092a83f274e673e9412aff6420ca715e (patch)
tree3342e17abe649b92d43c4f8030f7e13416fbb4dc
parentsys-process/minit: #375653 (diff)
downloadportage-2b390cfd092a83f274e673e9412aff6420ca715e.tar.xz
dev-libs/lzo: #374699
https://bugs.gentoo.org/show_bug.cgi?id=374699
-rw-r--r--dev-libs/lzo/Manifest4
-rw-r--r--dev-libs/lzo/files/lzo-BJA-configure.diff738
-rw-r--r--dev-libs/lzo/files/lzo-BJA-cross-win32.diff10
-rw-r--r--dev-libs/lzo/lzo-2.04.ebuild44
4 files changed, 796 insertions, 0 deletions
diff --git a/dev-libs/lzo/Manifest b/dev-libs/lzo/Manifest
new file mode 100644
index 00000000..af248a38
--- /dev/null
+++ b/dev-libs/lzo/Manifest
@@ -0,0 +1,4 @@
+AUX lzo-BJA-configure.diff 21603 RMD160 d34a2ac94237b25fa602836723eb6274c947c4e3 SHA1 f638820e073ca4e896c352a3bdff599e5e9fba95 SHA256 f554a1a9a2567a0caccc6fc6f05c5170182c695b423c4a0f81a292ca20edbf81
+AUX lzo-BJA-cross-win32.diff 202 RMD160 616a637b50d7feb820f9ef74d44a9061408d13d4 SHA1 8a129265cfffec539d1df1b9deae13595336e213 SHA256 af70887c6ac602a8522aed8c2242670623d20b93528ec08dc95a2c8969a9e737
+DIST lzo-2.04.tar.gz 604424 RMD160 8fcfcd45144d63db397ef1e8b1bd5140e456fdaf SHA1 f5bf5c7ae4116e60513e5788d156ef78946677e7 SHA256 4ee3a040facf39561f13e4ef2ab99a886fd68251a35d612486ed0625cc6ab428
+EBUILD lzo-2.04.ebuild 1100 RMD160 b5e0985aee371c87b837464be5dd7fe5eab6f1fb SHA1 8b6e8783be38ce7997254232297c548c9dc99edd SHA256 b8fac923b0c7fd935fa978f46c06596bee3e934e704642e67728750af5f3b33a
diff --git a/dev-libs/lzo/files/lzo-BJA-configure.diff b/dev-libs/lzo/files/lzo-BJA-configure.diff
new file mode 100644
index 00000000..8ee56bcd
--- /dev/null
+++ b/dev-libs/lzo/files/lzo-BJA-configure.diff
@@ -0,0 +1,738 @@
+--- /dev/null 2011-07-02 01:30:29.443800577 +0200
++++ m4/acc.m4 2011-07-10 14:16:06.000000000 +0200
+@@ -0,0 +1,362 @@
++# /***********************************************************************
++# // standard ACC macros
++# ************************************************************************/
++
++AC_DEFUN([mfx_ACC_CHECK_ENDIAN], [
++AC_C_BIGENDIAN([AC_DEFINE(ACC_ABI_BIG_ENDIAN,1,[Define to 1 if your machine is big endian.])],[AC_DEFINE(ACC_ABI_LITTLE_ENDIAN,1,[Define to 1 if your machine is little endian.])])
++])#
++
++AC_DEFUN([mfx_ACC_CHECK_HEADERS], [
++AC_HEADER_TIME
++AC_CHECK_HEADERS([assert.h ctype.h dirent.h errno.h fcntl.h float.h limits.h malloc.h memory.h setjmp.h signal.h stdarg.h stddef.h stdint.h stdio.h stdlib.h string.h strings.h time.h unistd.h utime.h sys/mman.h sys/resource.h sys/stat.h sys/time.h sys/types.h sys/wait.h])
++])#
++
++AC_DEFUN([mfx_ACC_CHECK_FUNCS], [
++AC_CHECK_FUNCS(access alloca atexit atoi atol chmod chown clock_getcpuclockid clock_getres clock_gettime ctime difftime fstat getenv getpagesize getrusage gettimeofday gmtime isatty localtime longjmp lstat memcmp memcpy memmove memset mkdir mktime mmap mprotect munmap qsort raise rmdir setjmp signal snprintf strcasecmp strchr strdup strerror strftime stricmp strncasecmp strnicmp strrchr strstr time umask utime vsnprintf)
++])#
++
++
++AC_DEFUN([mfx_ACC_CHECK_SIZEOF], [
++AC_CHECK_SIZEOF(short)
++AC_CHECK_SIZEOF(int)
++AC_CHECK_SIZEOF(long)
++
++AC_CHECK_SIZEOF(long long)
++AC_CHECK_SIZEOF(__int16)
++AC_CHECK_SIZEOF(__int32)
++AC_CHECK_SIZEOF(__int64)
++
++AC_CHECK_SIZEOF(void *)
++AC_CHECK_SIZEOF(size_t)
++AC_CHECK_SIZEOF(ptrdiff_t)
++])#
++
++
++# /***********************************************************************
++# // Check for ACC_conformance
++# ************************************************************************/
++
++AC_DEFUN([mfx_ACC_ACCCHK], [
++mfx_tmp=$1
++mfx_save_CPPFLAGS=$CPPFLAGS
++dnl in Makefile.in $(INCLUDES) will be before $(CPPFLAGS), so we mimic this here
++test "X$mfx_tmp" = "X" || CPPFLAGS="$mfx_tmp $CPPFLAGS"
++
++AC_MSG_CHECKING([whether your compiler passes the ACC conformance test])
++
++AC_LANG_CONFTEST([AC_LANG_PROGRAM(
++[[#define ACC_CONFIG_NO_HEADER 1
++#include "acc/acc.h"
++#include "acc/acc_incd.h"
++#undef ACCCHK_ASSERT
++#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT_HEADER(expr)
++#include "acc/acc_chk.ch"
++#undef ACCCHK_ASSERT
++static void test_acc_compile_time_assert(void) {
++#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT(expr)
++#include "acc/acc_chk.ch"
++#undef ACCCHK_ASSERT
++}
++#undef NDEBUG
++#include <assert.h>
++static int test_acc_run_time_assert(int r) {
++#define ACCCHK_ASSERT(expr) assert(expr);
++#include "acc/acc_chk.ch"
++#undef ACCCHK_ASSERT
++return r;
++}
++]], [[
++test_acc_compile_time_assert();
++if (test_acc_run_time_assert(1) != 1) return 1;
++]]
++)])
++
++mfx_tmp=FAILED
++_AC_COMPILE_IFELSE([], [mfx_tmp=yes])
++rm -f conftest.$ac_ext conftest.$ac_objext
++
++CPPFLAGS=$mfx_save_CPPFLAGS
++
++AC_MSG_RESULT([$mfx_tmp])
++case x$mfx_tmp in
++ xpassed | xyes) ;;
++ *)
++ AC_MSG_NOTICE([])
++ AC_MSG_NOTICE([Your compiler failed the ACC conformance test - for details see ])
++ AC_MSG_NOTICE([`config.log'. Please check that log file and consider sending])
++ AC_MSG_NOTICE([a patch or bug-report to <${PACKAGE_BUGREPORT}>.])
++ AC_MSG_NOTICE([Thanks for your support.])
++ AC_MSG_NOTICE([])
++ AC_MSG_ERROR([ACC conformance test failed. Stop.])
++dnl AS_EXIT
++ ;;
++esac
++])# mfx_ACC_ACCCHK
++
++
++# /***********************************************************************
++# // Check for ACC_conformance
++# ************************************************************************/
++
++AC_DEFUN([mfx_MINIACC_ACCCHK], [
++mfx_tmp=$1
++mfx_save_CPPFLAGS=$CPPFLAGS
++dnl in Makefile.in $(INCLUDES) will be before $(CPPFLAGS), so we mimic this here
++test "X$mfx_tmp" = "X" || CPPFLAGS="$mfx_tmp $CPPFLAGS"
++
++AC_MSG_CHECKING([whether your compiler passes the ACC conformance test])
++
++AC_LANG_CONFTEST([AC_LANG_PROGRAM(
++[[#define ACC_CONFIG_NO_HEADER 1
++#define ACC_WANT_ACC_INCD_H 1
++#include $2
++
++#define ACC_WANT_ACC_CHK_CH 1
++#undef ACCCHK_ASSERT
++#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT_HEADER(expr)
++#include $2
++
++#define ACC_WANT_ACC_CHK_CH 1
++#undef ACCCHK_ASSERT
++#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT(expr)
++static void test_acc_compile_time_assert(void) {
++#include $2
++}
++
++#undef NDEBUG
++#include <assert.h>
++#define ACC_WANT_ACC_CHK_CH 1
++#undef ACCCHK_ASSERT
++#define ACCCHK_ASSERT(expr) assert(expr);
++static int test_acc_run_time_assert(int r) {
++#include $2
++return r;
++}
++]], [[
++test_acc_compile_time_assert();
++if (test_acc_run_time_assert(1) != 1) return 1;
++]]
++)])
++
++mfx_tmp=FAILED
++_AC_COMPILE_IFELSE([], [mfx_tmp=yes])
++rm -f conftest.$ac_ext conftest.$ac_objext
++
++CPPFLAGS=$mfx_save_CPPFLAGS
++
++AC_MSG_RESULT([$mfx_tmp])
++case x$mfx_tmp in
++ xpassed | xyes) ;;
++ *)
++ AC_MSG_NOTICE([])
++ AC_MSG_NOTICE([Your compiler failed the ACC conformance test - for details see ])
++ AC_MSG_NOTICE([`config.log'. Please check that log file and consider sending])
++ AC_MSG_NOTICE([a patch or bug-report to <${PACKAGE_BUGREPORT}>.])
++ AC_MSG_NOTICE([Thanks for your support.])
++ AC_MSG_NOTICE([])
++ AC_MSG_ERROR([ACC conformance test failed. Stop.])
++dnl AS_EXIT
++ ;;
++esac
++])# mfx_MINIACC_ACCCHK
++
++
++
++# serial 1
++
++AC_DEFUN([mfx_PROG_CPPFLAGS], [
++AC_MSG_CHECKING([whether the C preprocessor needs special flags])
++
++AC_LANG_CONFTEST([AC_LANG_PROGRAM(
++[[#include <limits.h>
++#if (32767 >= 4294967295ul) || (65535u >= 4294967295ul)
++# include "your C preprocessor is broken 1"
++#elif (0xffffu == 0xfffffffful)
++# include "your C preprocessor is broken 2"
++#elif (32767 >= ULONG_MAX) || (65535u >= ULONG_MAX)
++# include "your C preprocessor is broken 3"
++#endif
++]], [[ ]]
++)])
++
++mfx_save_CPPFLAGS=$CPPFLAGS
++mfx_tmp=ERROR
++for mfx_arg in "" -no-cpp-precomp
++do
++ CPPFLAGS="$mfx_arg $mfx_save_CPPFLAGS"
++ _AC_COMPILE_IFELSE([],
++[mfx_tmp=$mfx_arg
++break])
++done
++CPPFLAGS=$mfx_save_CPPFLAGS
++rm -f conftest.$ac_ext conftest.$ac_objext
++case x$mfx_tmp in
++ x)
++ AC_MSG_RESULT([none needed]) ;;
++ xERROR)
++ AC_MSG_RESULT([ERROR])
++ AC_MSG_ERROR([your C preprocessor is broken - for details see config.log])
++ ;;
++ *)
++ AC_MSG_RESULT([$mfx_tmp])
++ CPPFLAGS="$mfx_tmp $CPPFLAGS"
++ ;;
++esac
++])# mfx_PROG_CPPFLAGS
++
++
++
++# serial 3
++
++AC_DEFUN([mfx_CHECK_HEADER_SANE_LIMITS_H], [
++AC_CACHE_CHECK([whether limits.h is sane],
++mfx_cv_header_sane_limits_h,
++[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <limits.h>
++#if (32767 >= 4294967295ul) || (65535u >= 4294967295ul)
++# if defined(__APPLE__) && defined(__GNUC__)
++# error "your preprocessor is broken - use compiler option -no-cpp-precomp"
++# else
++# include "your preprocessor is broken"
++# endif
++#endif
++#define MFX_0xffff 0xffff
++#define MFX_0xffffffffL 4294967295ul
++#if !defined(CHAR_BIT) || (CHAR_BIT != 8)
++# include "error CHAR_BIT"
++#endif
++#if !defined(UCHAR_MAX)
++# include "error UCHAR_MAX 1"
++#endif
++#if !defined(USHRT_MAX)
++# include "error USHRT_MAX 1"
++#endif
++#if !defined(UINT_MAX)
++# include "error UINT_MAX 1"
++#endif
++#if !defined(ULONG_MAX)
++# include "error ULONG_MAX 1"
++#endif
++#if !defined(SHRT_MAX)
++# include "error SHRT_MAX 1"
++#endif
++#if !defined(INT_MAX)
++# include "error INT_MAX 1"
++#endif
++#if !defined(LONG_MAX)
++# include "error LONG_MAX 1"
++#endif
++#if (UCHAR_MAX < 1)
++# include "error UCHAR_MAX 2"
++#endif
++#if (USHRT_MAX < 1)
++# include "error USHRT_MAX 2"
++#endif
++#if (UINT_MAX < 1)
++# include "error UINT_MAX 2"
++#endif
++#if (ULONG_MAX < 1)
++# include "error ULONG_MAX 2"
++#endif
++#if (UCHAR_MAX < 0xff)
++# include "error UCHAR_MAX 3"
++#endif
++#if (USHRT_MAX < MFX_0xffff)
++# include "error USHRT_MAX 3"
++#endif
++#if (UINT_MAX < MFX_0xffff)
++# include "error UINT_MAX 3"
++#endif
++#if (ULONG_MAX < MFX_0xffffffffL)
++# include "error ULONG_MAX 3"
++#endif
++#if (USHRT_MAX > UINT_MAX)
++# include "error USHRT_MAX vs UINT_MAX"
++#endif
++#if (UINT_MAX > ULONG_MAX)
++# include "error UINT_MAX vs ULONG_MAX"
++#endif
++]], [[
++#if (USHRT_MAX == MFX_0xffff)
++{ typedef char a_short2a[1 - 2 * !(sizeof(short) == 2)]; }
++#elif (USHRT_MAX >= MFX_0xffff)
++{ typedef char a_short2b[1 - 2 * !(sizeof(short) > 2)]; }
++#endif
++#if (UINT_MAX == MFX_0xffff)
++{ typedef char a_int2a[1 - 2 * !(sizeof(int) == 2)]; }
++#elif (UINT_MAX >= MFX_0xffff)
++{ typedef char a_int2b[1 - 2 * !(sizeof(int) > 2)]; }
++#endif
++#if (ULONG_MAX == MFX_0xffff)
++{ typedef char a_long2a[1 - 2 * !(sizeof(long) == 2)]; }
++#elif (ULONG_MAX >= MFX_0xffff)
++{ typedef char a_long2b[1 - 2 * !(sizeof(long) > 2)]; }
++#endif
++#if !defined(_CRAY1) /* CRAY PVP systems */
++#if (USHRT_MAX == MFX_0xffffffffL)
++{ typedef char a_short4a[1 - 2 * !(sizeof(short) == 4)]; }
++#elif (USHRT_MAX >= MFX_0xffffffffL)
++{ typedef char a_short4b[1 - 2 * !(sizeof(short) > 4)]; }
++#endif
++#endif /* _CRAY1 */
++#if (UINT_MAX == MFX_0xffffffffL)
++{ typedef char a_int4a[1 - 2 * !(sizeof(int) == 4)]; }
++#elif (UINT_MAX >= MFX_0xffffffffL)
++{ typedef char a_int4b[1 - 2 * !(sizeof(int) > 4)]; }
++#endif
++#if (ULONG_MAX == MFX_0xffffffffL)
++{ typedef char a_long4a[1 - 2 * !(sizeof(long) == 4)]; }
++#elif (ULONG_MAX >= MFX_0xffffffffL)
++{ typedef char a_long4b[1 - 2 * !(sizeof(long) > 4)]; }
++#endif
++]])],
++[mfx_cv_header_sane_limits_h=yes],
++[mfx_cv_header_sane_limits_h=no])])
++])
++
++# /***********************************************************************
++# // standard
++# ************************************************************************/
++
++AC_DEFUN([mfx_LZO_CHECK_ENDIAN], [
++AC_C_BIGENDIAN([AC_DEFINE(LZO_ABI_BIG_ENDIAN,1,[Define to 1 if your machine is big endian.])],[AC_DEFINE(LZO_ABI_LITTLE_ENDIAN,1,[Define to 1 if your machine is little endian.])])
++])#
++
++
++# /***********************************************************************
++# //
++# ************************************************************************/
++
++dnl more types which are not yet covered by ACC
++
++AC_DEFUN([mfx_CHECK_SIZEOF], [
++AC_CHECK_SIZEOF(__int32)
++AC_CHECK_SIZEOF(intmax_t)
++AC_CHECK_SIZEOF(uintmax_t)
++AC_CHECK_SIZEOF(intptr_t)
++AC_CHECK_SIZEOF(uintptr_t)
++
++AC_CHECK_SIZEOF(float)
++AC_CHECK_SIZEOF(double)
++AC_CHECK_SIZEOF(long double)
++
++AC_CHECK_SIZEOF(dev_t)
++AC_CHECK_SIZEOF(fpos_t)
++AC_CHECK_SIZEOF(mode_t)
++AC_CHECK_SIZEOF(off_t)
++AC_CHECK_SIZEOF(ssize_t)
++AC_CHECK_SIZEOF(time_t)
++])#
++
++
++
++AC_DEFUN([mfx_CHECK_LIB_WINMM], [
++if test "X$GCC" = Xyes; then
++case $host_os in
++cygwin* | mingw* | pw32*)
++ test "X$LIBS" != "X" && LIBS="$LIBS "
++ LIBS="${LIBS}-lwinmm" ;;
++*)
++ ;;
++esac
++fi
++])#
+--- aclocal.m4.ori 2011-07-10 14:23:13.000000000 +0200
++++ aclocal.m4 2011-07-10 14:24:33.000000000 +0200
+@@ -8056,370 +8056,6 @@
+ m4_ifndef([_LT_PROG_FC], [AC_DEFUN([_LT_PROG_FC])])
+ m4_ifndef([_LT_PROG_CXX], [AC_DEFUN([_LT_PROG_CXX])])
+
+-# /***********************************************************************
+-# // standard ACC macros
+-# ************************************************************************/
+-
+-AC_DEFUN([mfx_ACC_CHECK_ENDIAN], [
+-AC_C_BIGENDIAN([AC_DEFINE(ACC_ABI_BIG_ENDIAN,1,[Define to 1 if your machine is big endian.])],[AC_DEFINE(ACC_ABI_LITTLE_ENDIAN,1,[Define to 1 if your machine is little endian.])])
+-])#
+-
+-AC_DEFUN([mfx_ACC_CHECK_HEADERS], [
+-AC_HEADER_TIME
+-AC_CHECK_HEADERS([assert.h ctype.h dirent.h errno.h fcntl.h float.h limits.h malloc.h memory.h setjmp.h signal.h stdarg.h stddef.h stdint.h stdio.h stdlib.h string.h strings.h time.h unistd.h utime.h sys/mman.h sys/resource.h sys/stat.h sys/time.h sys/types.h sys/wait.h])
+-])#
+-
+-AC_DEFUN([mfx_ACC_CHECK_FUNCS], [
+-AC_CHECK_FUNCS(access alloca atexit atoi atol chmod chown clock_getcpuclockid clock_getres clock_gettime ctime difftime fstat getenv getpagesize getrusage gettimeofday gmtime isatty localtime longjmp lstat memcmp memcpy memmove memset mkdir mktime mmap mprotect munmap qsort raise rmdir setjmp signal snprintf strcasecmp strchr strdup strerror strftime stricmp strncasecmp strnicmp strrchr strstr time umask utime vsnprintf)
+-])#
+-
+-
+-AC_DEFUN([mfx_ACC_CHECK_SIZEOF], [
+-AC_CHECK_SIZEOF(short)
+-AC_CHECK_SIZEOF(int)
+-AC_CHECK_SIZEOF(long)
+-
+-AC_CHECK_SIZEOF(long long)
+-AC_CHECK_SIZEOF(__int16)
+-AC_CHECK_SIZEOF(__int32)
+-AC_CHECK_SIZEOF(__int64)
+-
+-AC_CHECK_SIZEOF(void *)
+-AC_CHECK_SIZEOF(size_t)
+-AC_CHECK_SIZEOF(ptrdiff_t)
+-])#
+-
+-
+-# /***********************************************************************
+-# // Check for ACC_conformance
+-# ************************************************************************/
+-
+-AC_DEFUN([mfx_ACC_ACCCHK], [
+-mfx_tmp=$1
+-mfx_save_CPPFLAGS=$CPPFLAGS
+-dnl in Makefile.in $(INCLUDES) will be before $(CPPFLAGS), so we mimic this here
+-test "X$mfx_tmp" = "X" || CPPFLAGS="$mfx_tmp $CPPFLAGS"
+-
+-AC_MSG_CHECKING([whether your compiler passes the ACC conformance test])
+-
+-AC_LANG_CONFTEST([AC_LANG_PROGRAM(
+-[[#define ACC_CONFIG_NO_HEADER 1
+-#include "acc/acc.h"
+-#include "acc/acc_incd.h"
+-#undef ACCCHK_ASSERT
+-#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT_HEADER(expr)
+-#include "acc/acc_chk.ch"
+-#undef ACCCHK_ASSERT
+-static void test_acc_compile_time_assert(void) {
+-#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT(expr)
+-#include "acc/acc_chk.ch"
+-#undef ACCCHK_ASSERT
+-}
+-#undef NDEBUG
+-#include <assert.h>
+-static int test_acc_run_time_assert(int r) {
+-#define ACCCHK_ASSERT(expr) assert(expr);
+-#include "acc/acc_chk.ch"
+-#undef ACCCHK_ASSERT
+-return r;
+-}
+-]], [[
+-test_acc_compile_time_assert();
+-if (test_acc_run_time_assert(1) != 1) return 1;
+-]]
+-)])
+-
+-mfx_tmp=FAILED
+-_AC_COMPILE_IFELSE([], [mfx_tmp=yes])
+-rm -f conftest.$ac_ext conftest.$ac_objext
+-
+-CPPFLAGS=$mfx_save_CPPFLAGS
+-
+-AC_MSG_RESULT([$mfx_tmp])
+-case x$mfx_tmp in
+- xpassed | xyes) ;;
+- *)
+- AC_MSG_NOTICE([])
+- AC_MSG_NOTICE([Your compiler failed the ACC conformance test - for details see ])
+- AC_MSG_NOTICE([`config.log'. Please check that log file and consider sending])
+- AC_MSG_NOTICE([a patch or bug-report to <${PACKAGE_BUGREPORT}>.])
+- AC_MSG_NOTICE([Thanks for your support.])
+- AC_MSG_NOTICE([])
+- AC_MSG_ERROR([ACC conformance test failed. Stop.])
+-dnl AS_EXIT
+- ;;
+-esac
+-])# mfx_ACC_ACCCHK
+-
+-
+-# /***********************************************************************
+-# // Check for ACC_conformance
+-# ************************************************************************/
+-
+-AC_DEFUN([mfx_MINIACC_ACCCHK], [
+-mfx_tmp=$1
+-mfx_save_CPPFLAGS=$CPPFLAGS
+-dnl in Makefile.in $(INCLUDES) will be before $(CPPFLAGS), so we mimic this here
+-test "X$mfx_tmp" = "X" || CPPFLAGS="$mfx_tmp $CPPFLAGS"
+-
+-AC_MSG_CHECKING([whether your compiler passes the ACC conformance test])
+-
+-AC_LANG_CONFTEST([AC_LANG_PROGRAM(
+-[[#define ACC_CONFIG_NO_HEADER 1
+-#define ACC_WANT_ACC_INCD_H 1
+-#include $2
+-
+-#define ACC_WANT_ACC_CHK_CH 1
+-#undef ACCCHK_ASSERT
+-#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT_HEADER(expr)
+-#include $2
+-
+-#define ACC_WANT_ACC_CHK_CH 1
+-#undef ACCCHK_ASSERT
+-#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT(expr)
+-static void test_acc_compile_time_assert(void) {
+-#include $2
+-}
+-
+-#undef NDEBUG
+-#include <assert.h>
+-#define ACC_WANT_ACC_CHK_CH 1
+-#undef ACCCHK_ASSERT
+-#define ACCCHK_ASSERT(expr) assert(expr);
+-static int test_acc_run_time_assert(int r) {
+-#include $2
+-return r;
+-}
+-]], [[
+-test_acc_compile_time_assert();
+-if (test_acc_run_time_assert(1) != 1) return 1;
+-]]
+-)])
+-
+-mfx_tmp=FAILED
+-_AC_COMPILE_IFELSE([], [mfx_tmp=yes])
+-rm -f conftest.$ac_ext conftest.$ac_objext
+-
+-CPPFLAGS=$mfx_save_CPPFLAGS
+-
+-AC_MSG_RESULT([$mfx_tmp])
+-case x$mfx_tmp in
+- xpassed | xyes) ;;
+- *)
+- AC_MSG_NOTICE([])
+- AC_MSG_NOTICE([Your compiler failed the ACC conformance test - for details see ])
+- AC_MSG_NOTICE([`config.log'. Please check that log file and consider sending])
+- AC_MSG_NOTICE([a patch or bug-report to <${PACKAGE_BUGREPORT}>.])
+- AC_MSG_NOTICE([Thanks for your support.])
+- AC_MSG_NOTICE([])
+- AC_MSG_ERROR([ACC conformance test failed. Stop.])
+-dnl AS_EXIT
+- ;;
+-esac
+-])# mfx_MINIACC_ACCCHK
+-
+-
+-
+-# serial 1
+-
+-AC_DEFUN([mfx_PROG_CPPFLAGS], [
+-AC_MSG_CHECKING([whether the C preprocessor needs special flags])
+-
+-AC_LANG_CONFTEST([AC_LANG_PROGRAM(
+-[[#include <limits.h>
+-#if (32767 >= 4294967295ul) || (65535u >= 4294967295ul)
+-# include "your C preprocessor is broken 1"
+-#elif (0xffffu == 0xfffffffful)
+-# include "your C preprocessor is broken 2"
+-#elif (32767 >= ULONG_MAX) || (65535u >= ULONG_MAX)
+-# include "your C preprocessor is broken 3"
+-#endif
+-]], [[ ]]
+-)])
+-
+-mfx_save_CPPFLAGS=$CPPFLAGS
+-mfx_tmp=ERROR
+-for mfx_arg in "" -no-cpp-precomp
+-do
+- CPPFLAGS="$mfx_arg $mfx_save_CPPFLAGS"
+- _AC_COMPILE_IFELSE([],
+-[mfx_tmp=$mfx_arg
+-break])
+-done
+-CPPFLAGS=$mfx_save_CPPFLAGS
+-rm -f conftest.$ac_ext conftest.$ac_objext
+-case x$mfx_tmp in
+- x)
+- AC_MSG_RESULT([none needed]) ;;
+- xERROR)
+- AC_MSG_RESULT([ERROR])
+- AC_MSG_ERROR([your C preprocessor is broken - for details see config.log])
+- ;;
+- *)
+- AC_MSG_RESULT([$mfx_tmp])
+- CPPFLAGS="$mfx_tmp $CPPFLAGS"
+- ;;
+-esac
+-])# mfx_PROG_CPPFLAGS
+-
+-
+-
+-# serial 3
+-
+-AC_DEFUN([mfx_CHECK_HEADER_SANE_LIMITS_H], [
+-AC_CACHE_CHECK([whether limits.h is sane],
+-mfx_cv_header_sane_limits_h,
+-[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <limits.h>
+-#if (32767 >= 4294967295ul) || (65535u >= 4294967295ul)
+-# if defined(__APPLE__) && defined(__GNUC__)
+-# error "your preprocessor is broken - use compiler option -no-cpp-precomp"
+-# else
+-# include "your preprocessor is broken"
+-# endif
+-#endif
+-#define MFX_0xffff 0xffff
+-#define MFX_0xffffffffL 4294967295ul
+-#if !defined(CHAR_BIT) || (CHAR_BIT != 8)
+-# include "error CHAR_BIT"
+-#endif
+-#if !defined(UCHAR_MAX)
+-# include "error UCHAR_MAX 1"
+-#endif
+-#if !defined(USHRT_MAX)
+-# include "error USHRT_MAX 1"
+-#endif
+-#if !defined(UINT_MAX)
+-# include "error UINT_MAX 1"
+-#endif
+-#if !defined(ULONG_MAX)
+-# include "error ULONG_MAX 1"
+-#endif
+-#if !defined(SHRT_MAX)
+-# include "error SHRT_MAX 1"
+-#endif
+-#if !defined(INT_MAX)
+-# include "error INT_MAX 1"
+-#endif
+-#if !defined(LONG_MAX)
+-# include "error LONG_MAX 1"
+-#endif
+-#if (UCHAR_MAX < 1)
+-# include "error UCHAR_MAX 2"
+-#endif
+-#if (USHRT_MAX < 1)
+-# include "error USHRT_MAX 2"
+-#endif
+-#if (UINT_MAX < 1)
+-# include "error UINT_MAX 2"
+-#endif
+-#if (ULONG_MAX < 1)
+-# include "error ULONG_MAX 2"
+-#endif
+-#if (UCHAR_MAX < 0xff)
+-# include "error UCHAR_MAX 3"
+-#endif
+-#if (USHRT_MAX < MFX_0xffff)
+-# include "error USHRT_MAX 3"
+-#endif
+-#if (UINT_MAX < MFX_0xffff)
+-# include "error UINT_MAX 3"
+-#endif
+-#if (ULONG_MAX < MFX_0xffffffffL)
+-# include "error ULONG_MAX 3"
+-#endif
+-#if (USHRT_MAX > UINT_MAX)
+-# include "error USHRT_MAX vs UINT_MAX"
+-#endif
+-#if (UINT_MAX > ULONG_MAX)
+-# include "error UINT_MAX vs ULONG_MAX"
+-#endif
+-]], [[
+-#if (USHRT_MAX == MFX_0xffff)
+-{ typedef char a_short2a[1 - 2 * !(sizeof(short) == 2)]; }
+-#elif (USHRT_MAX >= MFX_0xffff)
+-{ typedef char a_short2b[1 - 2 * !(sizeof(short) > 2)]; }
+-#endif
+-#if (UINT_MAX == MFX_0xffff)
+-{ typedef char a_int2a[1 - 2 * !(sizeof(int) == 2)]; }
+-#elif (UINT_MAX >= MFX_0xffff)
+-{ typedef char a_int2b[1 - 2 * !(sizeof(int) > 2)]; }
+-#endif
+-#if (ULONG_MAX == MFX_0xffff)
+-{ typedef char a_long2a[1 - 2 * !(sizeof(long) == 2)]; }
+-#elif (ULONG_MAX >= MFX_0xffff)
+-{ typedef char a_long2b[1 - 2 * !(sizeof(long) > 2)]; }
+-#endif
+-#if !defined(_CRAY1) /* CRAY PVP systems */
+-#if (USHRT_MAX == MFX_0xffffffffL)
+-{ typedef char a_short4a[1 - 2 * !(sizeof(short) == 4)]; }
+-#elif (USHRT_MAX >= MFX_0xffffffffL)
+-{ typedef char a_short4b[1 - 2 * !(sizeof(short) > 4)]; }
+-#endif
+-#endif /* _CRAY1 */
+-#if (UINT_MAX == MFX_0xffffffffL)
+-{ typedef char a_int4a[1 - 2 * !(sizeof(int) == 4)]; }
+-#elif (UINT_MAX >= MFX_0xffffffffL)
+-{ typedef char a_int4b[1 - 2 * !(sizeof(int) > 4)]; }
+-#endif
+-#if (ULONG_MAX == MFX_0xffffffffL)
+-{ typedef char a_long4a[1 - 2 * !(sizeof(long) == 4)]; }
+-#elif (ULONG_MAX >= MFX_0xffffffffL)
+-{ typedef char a_long4b[1 - 2 * !(sizeof(long) > 4)]; }
+-#endif
+-]])],
+-[mfx_cv_header_sane_limits_h=yes],
+-[mfx_cv_header_sane_limits_h=no])])
+-])
+-
+-# /***********************************************************************
+-# // standard
+-# ************************************************************************/
+-
+-AC_DEFUN([mfx_LZO_CHECK_ENDIAN], [
+-AC_C_BIGENDIAN([AC_DEFINE(LZO_ABI_BIG_ENDIAN,1,[Define to 1 if your machine is big endian.])],[AC_DEFINE(LZO_ABI_LITTLE_ENDIAN,1,[Define to 1 if your machine is little endian.])])
+-])#
+-
+-
+-# /***********************************************************************
+-# //
+-# ************************************************************************/
+-
+-dnl more types which are not yet covered by ACC
+-
+-AC_DEFUN([mfx_CHECK_SIZEOF], [
+-AC_CHECK_SIZEOF(__int32)
+-AC_CHECK_SIZEOF(intmax_t)
+-AC_CHECK_SIZEOF(uintmax_t)
+-AC_CHECK_SIZEOF(intptr_t)
+-AC_CHECK_SIZEOF(uintptr_t)
+-
+-AC_CHECK_SIZEOF(float)
+-AC_CHECK_SIZEOF(double)
+-AC_CHECK_SIZEOF(long double)
+-
+-AC_CHECK_SIZEOF(dev_t)
+-AC_CHECK_SIZEOF(fpos_t)
+-AC_CHECK_SIZEOF(mode_t)
+-AC_CHECK_SIZEOF(off_t)
+-AC_CHECK_SIZEOF(ssize_t)
+-AC_CHECK_SIZEOF(time_t)
+-])#
+-
+-
+-
+-AC_DEFUN([mfx_CHECK_LIB_WINMM], [
+-if test "X$GCC" = Xyes; then
+-case $host_os in
+-cygwin* | mingw* | pw32*)
+- test "X$LIBS" != "X" && LIBS="$LIBS "
+- LIBS="${LIBS}-lwinmm" ;;
+-*)
+- ;;
+-esac
+-fi
+-])#
+-
+-
+ # Copyright (C) 2002, 2003, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
+ #
+ # This file is free software; the Free Software Foundation
diff --git a/dev-libs/lzo/files/lzo-BJA-cross-win32.diff b/dev-libs/lzo/files/lzo-BJA-cross-win32.diff
new file mode 100644
index 00000000..0c91e5b5
--- /dev/null
+++ b/dev-libs/lzo/files/lzo-BJA-cross-win32.diff
@@ -0,0 +1,10 @@
+--- configure.ac.ori 2011-07-10 14:04:57.000000000 +0200
++++ configure.ac 2011-07-10 14:05:55.000000000 +0200
+@@ -70,6 +70,7 @@
+
+ AC_ENABLE_STATIC
+ AC_DISABLE_SHARED
++AC_LIBTOOL_WIN32_DLL
+ LT_INIT
+
+
diff --git a/dev-libs/lzo/lzo-2.04.ebuild b/dev-libs/lzo/lzo-2.04.ebuild
new file mode 100644
index 00000000..21d73303
--- /dev/null
+++ b/dev-libs/lzo/lzo-2.04.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/lzo/lzo-2.04.ebuild,v 1.7 2011/03/23 17:58:53 xarthisius Exp $
+
+EAPI=2
+#inherit autotools flag-o-matic
+inherit flag-o-matic
+
+DESCRIPTION="An extremely fast compression and decompression library"
+HOMEPAGE="http://www.oberhumer.com/opensource/lzo/"
+SRC_URI="http://www.oberhumer.com/opensource/lzo/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="examples static-libs"
+
+#src_prepare () {
+# epatch "${FILESDIR}/${PN}-BJA-configure.diff"
+#
+# AT_M4DIR=m4
+# eautoreconf
+#}
+
+src_configure() {
+ append-ldflags -no-undefined
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS doc/*
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h}
+ fi
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}