summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2011-07-26 20:14:11 +0200
committerBertrand Jacquin <beber@meleeweb.net>2011-07-26 20:14:11 +0200
commitc67698bd455299fe927db11c504d40981e0f9164 (patch)
treea49bafd27ebc7c8817efc7a6e9e50aa043db2b42
parentbusybox dfc (diff)
downloadportage-c67698bd455299fe927db11c504d40981e0f9164.tar.xz
sys-process/minit: #375653
https://bugs.gentoo.org/show_bug.cgi?id=375653
-rw-r--r--sys-process/minit/Manifest3
-rw-r--r--sys-process/minit/files/0.9.1-destdir.patch16
-rw-r--r--sys-process/minit/minit-0.9.1.ebuild31
3 files changed, 50 insertions, 0 deletions
diff --git a/sys-process/minit/Manifest b/sys-process/minit/Manifest
new file mode 100644
index 00000000..fd8e79ef
--- /dev/null
+++ b/sys-process/minit/Manifest
@@ -0,0 +1,3 @@
+AUX 0.9.1-destdir.patch 622 RMD160 780697bdfc21460284c6842cbea10c0563567c0b SHA1 bfd98fc1e9fc5c3656277c6c7f6552ff7481fa8c SHA256 3e9f633a6f9c02a61a68d85c1bd8308d26898379d5fa31fd8dac88381e522d19
+DIST minit-0.9.1.tar.bz2 21894 RMD160 48ddd675fc13dbf57afd26224e83a9c4a8aa8946 SHA1 c0f4ac571012daadc2b581683e861cfbe4d997e8 SHA256 8128b6b96dbe31072005acb63005d77f052a98393c455a725c2ac5054d561d22
+EBUILD minit-0.9.1.ebuild 691 RMD160 4d1c46b0dafc746ffbebef2d364056af8fa027f4 SHA1 7cffea179014748185fc4a36ebcea3b0fb825574 SHA256 6d666fca5d5ddf969a409a91f58e3253072275f3163abee75e2819b218673b02
diff --git a/sys-process/minit/files/0.9.1-destdir.patch b/sys-process/minit/files/0.9.1-destdir.patch
new file mode 100644
index 00000000..7a36d3cd
--- /dev/null
+++ b/sys-process/minit/files/0.9.1-destdir.patch
@@ -0,0 +1,16 @@
+--- Makefile.orig 2004-03-04 03:08:18.967017104 -0500
++++ Makefile 2004-03-04 03:10:11.445917712 -0500
+@@ -36,10 +36,12 @@
+ $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+
+ install-files:
++ test -d $(DESTDIR)/sbin || mkdir -p $(DESTDIR)/sbin
+ install minit pidfilehack $(DESTDIR)/sbin
+ install write_proc hard-reboot $(DESTDIR)/sbin
++ test -d $(DESTDIR)/bin || mkdir -p $(DESTDIR)/bin
+ install msvc $(DESTDIR)/bin
+- test -d $(DESTDIR)/etc/minit || mkdir $(DESTDIR)/etc/minit
++ test -d $(DESTDIR)/etc/minit || mkdir -p $(DESTDIR)/etc/minit
+
+ install-fifos:
+ -mkfifo -m 600 $(DESTDIR)/etc/minit/in $(DESTDIR)/etc/minit/out
diff --git a/sys-process/minit/minit-0.9.1.ebuild b/sys-process/minit/minit-0.9.1.ebuild
new file mode 100644
index 00000000..fec989e6
--- /dev/null
+++ b/sys-process/minit/minit-0.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/minit/minit-0.9.1.ebuild,v 1.5 2006/01/23 23:59:55 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="a small yet feature-complete init"
+HOMEPAGE="http://www.fefe.de/minit/"
+SRC_URI="http://www.fefe.de/minit/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-destdir.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" DIET="" CC="$(tc-getCC)"|| die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc CHANGES README TODO
+}