summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-09-26 17:51:49 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 01:19:04 +0100
commit0997d4d128e07e0b0e9c097046e41617f03132cb (patch)
treee6a9b0c0ef9b1fa2886765204ddd232ebc893f61
parentwww-servers/httpterm: move to EAPI 7 (diff)
downloadportage-0997d4d128e07e0b0e9c097046e41617f03132cb.tar.xz
www-apps/phabricator: move to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1
-rw-r--r--www-apps/phabricator/phabricator-20191213.ebuild10
-rw-r--r--www-apps/phabricator/phabricator-9999.ebuild10
2 files changed, 12 insertions, 8 deletions
diff --git a/www-apps/phabricator/phabricator-20191213.ebuild b/www-apps/phabricator/phabricator-20191213.ebuild
index 76222511..501b1589 100644
--- a/www-apps/phabricator/phabricator-20191213.ebuild
+++ b/www-apps/phabricator/phabricator-20191213.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
WEBAPP_NO_AUTO_INSTALL=yes
WEBAPP_MANUAL_SLOT=yes
inherit git-r3 webapp
@@ -46,6 +46,11 @@ RDEPEND=">=app-admin/webapp-config-1.51-r1:0
mail? ( dev-php/pecl-mailparse:7 )"
PDEPEND="extension-sprint? ( www-apps/phabricator-extensions-Sprint )"
+PATCHES=(
+ "${FILESDIR}/${PV}-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch"
+ "${FILESDIR}/${PV}-blacklists-for-registering-users.patch"
+)
+
pkg_setup() {
webapp_pkg_setup
@@ -66,9 +71,6 @@ src_prepare() {
git remote add origin "${EGIT_REPO_URI}"
git remote -v > "${S}/GIT_REMOTE_INFO"
- eapply "${FILESDIR}/${PV}-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch"
- eapply "${FILESDIR}/${PV}-blacklists-for-registering-users.patch"
-
find -type f -name .gitignore -print0 \
| xargs -0 --no-run-if-empty -- \
rm
diff --git a/www-apps/phabricator/phabricator-9999.ebuild b/www-apps/phabricator/phabricator-9999.ebuild
index c7bea6bd..bb7ee475 100644
--- a/www-apps/phabricator/phabricator-9999.ebuild
+++ b/www-apps/phabricator/phabricator-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
WEBAPP_NO_AUTO_INSTALL=yes
WEBAPP_MANUAL_SLOT=yes
inherit git-r3 webapp
@@ -44,6 +44,11 @@ RDEPEND=">=app-admin/webapp-config-1.51-r1:0
mail? ( dev-php/pecl-mailparse:7 )"
PDEPEND="extension-sprint? ( =www-apps/phabricator-extensions-Sprint-${PV} )"
+PATCHES=(
+ "${FILESDIR}/${PV}-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch"
+ "${FILESDIR}/${PV}-blacklists-for-registering-users.patch"
+)
+
pkg_setup() {
webapp_pkg_setup
@@ -64,9 +69,6 @@ src_prepare() {
git remote add origin "${EGIT_REPO_URI}"
git remote -v > "${S}/GIT_REMOTE_INFO"
- eapply "${FILESDIR}/${PV}-MEDIUM-Get-VERSION-for-files-in-usr-share-PN-GIT_COM.patch"
- eapply "${FILESDIR}/${PV}-blacklists-for-registering-users.patch"
-
find -type f -name .gitignore -print0 \
| xargs -0 --no-run-if-empty -- \
rm