summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-09-26 17:48:27 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 01:19:04 +0100
commite0d0b36b06f1a32a21c5ad1cf46058e2f23e7a1a (patch)
treec5e6429d0d7f0a92f50de22f719792cbbf5c019c
parentwww-client/arcanist: move to EAPI 7 (diff)
downloadportage-e0d0b36b06f1a32a21c5ad1cf46058e2f23e7a1a.tar.xz
www-servers/httpterm: move to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1
-rw-r--r--www-servers/httpterm/httpterm-1.7.2.ebuild7
-rw-r--r--www-servers/httpterm/httpterm-9999.ebuild15
2 files changed, 7 insertions, 15 deletions
diff --git a/www-servers/httpterm/httpterm-1.7.2.ebuild b/www-servers/httpterm/httpterm-1.7.2.ebuild
index ce7988a7..5ac76c15 100644
--- a/www-servers/httpterm/httpterm-1.7.2.ebuild
+++ b/www-servers/httpterm/httpterm-1.7.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit eutils toolchain-funcs
DESCRIPTION="HTTP termination for benchmarks"
@@ -13,9 +13,6 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
src_compile() {
local -a args=(
# This is for recent Linux 2.6 with splice and accept4()
diff --git a/www-servers/httpterm/httpterm-9999.ebuild b/www-servers/httpterm/httpterm-9999.ebuild
index 40bc1792..ff41b349 100644
--- a/www-servers/httpterm/httpterm-9999.ebuild
+++ b/www-servers/httpterm/httpterm-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit eutils toolchain-funcs git-r3
DESCRIPTION="HTTP termination for benchmarks"
@@ -13,14 +13,9 @@ SLOT="0"
KEYWORDS=""
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
-
- eapply "${FILESDIR}/${PV}-BUILD-INT_MAX-requires-limits.h.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${PV}-BUILD-INT_MAX-requires-limits.h.patch"
+)
src_compile() {
local -a args=(