aboutsummaryrefslogtreecommitdiff
path: root/src/xzdec/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2008-11-19 23:52:24 +0200
committerLasse Collin <lasse.collin@tukaani.org>2008-11-19 23:52:24 +0200
commit1880a3927b23f265f63b2adb86fbdb81ea09eb06 (patch)
tree2fe1b65d21f81b28f46eb707378d97f553e99ee1 /src/xzdec/Makefile.am
parentOh well, big messy commit again. Some highlights: (diff)
downloadxz-1880a3927b23f265f63b2adb86fbdb81ea09eb06.tar.xz
Renamed lzma to xz and lzmadec to xzdec. We create symlinks
lzma, unlzma, and lzcat in "make install" for backwards compatibility with LZMA Utils 4.32.x; I'm not sure if this should be the default though.
Diffstat (limited to 'src/xzdec/Makefile.am')
-rw-r--r--src/xzdec/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/xzdec/Makefile.am b/src/xzdec/Makefile.am
new file mode 100644
index 00000000..8c8cae80
--- /dev/null
+++ b/src/xzdec/Makefile.am
@@ -0,0 +1,29 @@
+##
+## Copyright (C) 2007 Lasse Collin
+##
+## This program is free software; you can redistribute it and/or
+## modify it under the terms of the GNU Lesser General Public
+## License as published by the Free Software Foundation; either
+## version 2.1 of the License, or (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+## Lesser General Public License for more details.
+##
+
+bin_PROGRAMS = xzdec
+
+xzdec_SOURCES = xzdec.c
+xzdec_CPPFLAGS = \
+ -I@top_srcdir@/src/common \
+ -I@top_srcdir@/src/liblzma/api \
+ -I@top_builddir@/lib
+xzdec_LDFLAGS = -static
+xzdec_LDADD = \
+ @top_builddir@/src/liblzma/liblzma.la \
+ @LTLIBINTL@
+
+if COND_GNULIB
+xzdec_LDADD += @top_builddir@/lib/libgnu.a
+endif