aboutsummaryrefslogtreecommitdiff
path: root/src/liblzma/common/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2008-01-19 15:19:21 +0200
committerLasse Collin <lasse.collin@tukaani.org>2008-01-19 15:19:21 +0200
commit23c227a864a3b69f38c6a74306161d4e6918d1cc (patch)
tree49bfe24e15c1df35589635f8630a9e44dc7604a2 /src/liblzma/common/Makefile.am
parentAdded the debug directory and the first debug tool (diff)
downloadxz-23c227a864a3b69f38c6a74306161d4e6918d1cc.tar.xz
Revised the Delta filter implementation. The initialization
function is still shared between encoder and decoder, but the actual coding is in separate files for encoder and decoder. There are now separate functions for the actual delta calculation depending on if Delta is the last filter in the chain or not. If it is the last, the new code copies the data from input to output buffer and does the delta calculation at the same time. The old code first copied the data, then did the delta in the target buffer, which required reading through the data twice. Support for LZMA_SYNC_FLUSH was added to the Delta encoder. This doesn't change anything in the file format.
Diffstat (limited to 'src/liblzma/common/Makefile.am')
-rw-r--r--src/liblzma/common/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/liblzma/common/Makefile.am b/src/liblzma/common/Makefile.am
index a2eacfd8..048f4c73 100644
--- a/src/liblzma/common/Makefile.am
+++ b/src/liblzma/common/Makefile.am
@@ -48,8 +48,18 @@ endif
if COND_FILTER_DELTA
libcommon_la_SOURCES += \
- delta_coder.c \
- delta_coder.h
+ delta_common.c \
+ delta_common.h
+if COND_MAIN_ENCODER
+libcommon_la_SOURCES += \
+ delta_encoder.c \
+ delta_encoder.h
+endif
+if COND_MAIN_DECODER
+libcommon_la_SOURCES += \
+ delta_decoder.c \
+ delta_decoder.h
+endif
endif
if COND_MAIN_ENCODER