aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2024-03-09 09:49:55 +0800
committerJia Tan <jiat0218@gmail.com>2024-03-09 09:49:55 +0800
commitb93a8d7631d9517da63f03e0185455024a4609e8 (patch)
tree01687e6c34addcc79a32a05d6fb1ec74d6ca102d /configure.ac
parentliblzma: Fix false Valgrind error report with GCC. (diff)
downloadxz-b93a8d7631d9517da63f03e0185455024a4609e8.tar.xz
Tests: Replace HAVE_MICROLZMA usage in CMake and Autotools builds.
This reverts commit adaacafde6661496ca2814b1e94a3ba5186428cb.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 2 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 176bb9ce..075567f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -304,13 +304,8 @@ AC_ARG_ENABLE([microlzma], AS_HELP_STRING([--disable-microlzma],
for example, erofs-utils.]),
[], [enable_microlzma=yes])
case $enable_microlzma in
- yes)
- AC_DEFINE([HAVE_MICROLZMA], [1],
- [Define to 1 if MicroLZMA support is enabled.])
- AC_MSG_RESULT([yes])
- ;;
- no)
- AC_MSG_RESULT([no])
+ yes | no)
+ AC_MSG_RESULT([$enable_microlzma])
;;
*)
AC_MSG_RESULT([])