aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2023-10-09 18:13:08 +0300
committerLasse Collin <lasse.collin@tukaani.org>2023-10-22 19:03:52 +0300
commit2e2cd11535ad77364cf021297e0b3f162fa3a3d0 (patch)
tree4623ea1dc5da7596b1f5d2de885b466f9bf45a1f /configure.ac
parentxz/Windows: Allow clock_gettime with POSIX threads. (diff)
downloadxz-2e2cd11535ad77364cf021297e0b3f162fa3a3d0.tar.xz
Simplify detection of Capsicum support.
This removes support for FreeBSD 10.0 and 10.1 which used <sys/capability.h> instead of <sys/capsicum.h>. Support for FreeBSD 10.1 ended on 2016-12-31. So now FreeBSD >= 10.2 is required to enable Capsicum support. This also removes support for Capsicum on Linux (libcaprights) which seems to have been unmaintained since 2017 and Linux 4.11: https://github.com/google/capsicum-linux
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6512f480..9d35071a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1051,12 +1051,12 @@ AM_CONDITIONAL([COND_CRC_CLMUL], [test "x$enable_clmul_crc" = xyes])
# Check for sandbox support. If one is found, set enable_sandbox=found.
AS_CASE([$enable_sandbox],
[auto | capsicum], [
- AX_CHECK_CAPSICUM([enable_sandbox=found], [:])
+ AC_CHECK_FUNCS([cap_rights_limit], [enable_sandbox=found])
]
)
AS_CASE([$enable_sandbox],
[auto | pledge], [
- AC_CHECK_FUNCS([pledge], [enable_sandbox=found ; break])
+ AC_CHECK_FUNCS([pledge], [enable_sandbox=found])
]
)