aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2023-09-21 20:36:31 +0300
committerJia Tan <jiat0218@gmail.com>2023-10-31 18:44:59 +0800
commit1595f454d5c8257c668cccd6a86dd68175d5c430 (patch)
treec9272cbbbe40c7531ebd48ee0df00198ed187931 /CMakeLists.txt
parentCMake: Bump maximum policy version to 3.27. (diff)
downloadxz-1595f454d5c8257c668cccd6a86dd68175d5c430.tar.xz
CMake: Add a comment about threads on Cygwin.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9994f936..f6bdc47d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -364,6 +364,7 @@ if(ENABLE_THREADS)
find_package(Threads REQUIRED)
# If both Windows and posix threading are available, prefer Windows.
+ # Note that on Cygwin CMAKE_USE_WIN32_THREADS_INIT is false.
if(CMAKE_USE_WIN32_THREADS_INIT AND NOT ENABLE_THREADS STREQUAL "posix")
if(ENABLE_THREADS STREQUAL "win95"
OR (ENABLE_THREADS STREQUAL "ON"