aboutsummaryrefslogtreecommitdiff
path: root/external/qrcodegen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'external/qrcodegen/CMakeLists.txt')
-rw-r--r--external/qrcodegen/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/external/qrcodegen/CMakeLists.txt b/external/qrcodegen/CMakeLists.txt
new file mode 100644
index 000000000..a9060e3e8
--- /dev/null
+++ b/external/qrcodegen/CMakeLists.txt
@@ -0,0 +1,7 @@
+project(libqrcodegen)
+
+add_library(qrcodegen STATIC QrCode.cpp)
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
+
+target_include_directories(qrcodegen PUBLIC
+ ${CMAKE_CURRENT_SOURCE_DIR})