aboutsummaryrefslogtreecommitdiff
path: root/external/qrcodegen/CMakeLists.txt
diff options
context:
space:
mode:
authorselsta <selsta@sent.at>2020-04-29 17:53:29 +0200
committerselsta <selsta@sent.at>2020-06-21 20:15:10 +0200
commit99684e3ec3c613186a5c2fcc9844e817457d806d (patch)
tree6382ef9f5b3e1e9a043205befcd5ddccceb10094 /external/qrcodegen/CMakeLists.txt
parentMerge pull request #6460 (diff)
downloadmonero-99684e3ec3c613186a5c2fcc9844e817457d806d.tar.xz
simplewallet: add show_qr_code command
Thanks to iDunk for helping with Windows.
Diffstat (limited to 'external/qrcodegen/CMakeLists.txt')
-rw-r--r--external/qrcodegen/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/external/qrcodegen/CMakeLists.txt b/external/qrcodegen/CMakeLists.txt
new file mode 100644
index 000000000..a9060e3e8
--- /dev/null
+++ b/external/qrcodegen/CMakeLists.txt
@@ -0,0 +1,7 @@
+project(libqrcodegen)
+
+add_library(qrcodegen STATIC QrCode.cpp)
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
+
+target_include_directories(qrcodegen PUBLIC
+ ${CMAKE_CURRENT_SOURCE_DIR})