aboutsummaryrefslogtreecommitdiff
path: root/tests/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
authorluigi1111 <luigi1111w@gmail.com>2020-06-19 10:17:51 -0500
committerluigi1111 <luigi1111w@gmail.com>2020-06-19 10:17:51 -0500
commit93257997bd69e25c76de8ebf3f46bfeb44f11589 (patch)
tree1b9cf72c5a4911ca7ba449353a080be431a17c45 /tests/fuzz/CMakeLists.txt
parentMerge pull request #6637 (diff)
parentfuzz_tests: fix init check in oss-fuzz mode (diff)
downloadmonero-93257997bd69e25c76de8ebf3f46bfeb44f11589.tar.xz
Merge pull request #6656
bde7f1c fuzz_tests: fix init check in oss-fuzz mode (moneromooo-monero) c4b7420 Do not use PIE with OSS-Fuzz (moneromooo-monero) c4df8b1 fix leaks in fuzz tests (moneromooo-monero) 38ca1bb fuzz_tests: add a tx extra fuzz test (moneromooo-monero)
Diffstat (limited to 'tests/fuzz/CMakeLists.txt')
-rw-r--r--tests/fuzz/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/fuzz/CMakeLists.txt b/tests/fuzz/CMakeLists.txt
index 8654d41d5..606fec465 100644
--- a/tests/fuzz/CMakeLists.txt
+++ b/tests/fuzz/CMakeLists.txt
@@ -200,3 +200,21 @@ set_property(TARGET bulletproof_fuzz_tests
PROPERTY
FOLDER "tests")
+add_executable(tx-extra_fuzz_tests tx-extra.cpp fuzzer.cpp)
+target_link_libraries(tx-extra_fuzz_tests
+ PRIVATE
+ cryptonote_basic
+ common
+ epee
+ ${Boost_THREAD_LIBRARY}
+ ${Boost_CHRONO_LIBRARY}
+ ${Boost_REGEX_LIBRARY}
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${Boost_SYSTEM_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES}
+ $ENV{LIB_FUZZING_ENGINE})
+set_property(TARGET tx-extra_fuzz_tests
+ PROPERTY
+ FOLDER "tests")
+