aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-06-24 12:38:41 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-06-24 16:46:18 +0100
commit841231e5bd0d90e8a57d6fd997701a70ef520730 (patch)
tree0fc42786a1302b126187bc12b935f6f4accca10c /tests/CMakeLists.txt
parentMerge pull request #2087 (diff)
downloadmonero-841231e5bd0d90e8a57d6fd997701a70ef520730.tar.xz
Add fuzz testing using american fuzzy lop
Existing tests: block, transaction, signature, cold outputs, cold transaction. Data for these is in tests/data/fuzz. A convenience shell script is in contrib/fuzz_testing/fuzz.sh, eg: contrib/fuzz_testing/fuzz.sh signature The fuzzer will run indefinitely, ^C to stop. Fuzzing is currently supported for GCC only. I can't get CLANG to build Monero here as it dies on some system headers, so if someone wants to make it work on both, that'd be great. In particular, the __AFL_LOOP construct should be made to work so that a given run can fuzz multiple inputs, as the C++ load time is substantial.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index cb29b27a0..85763f8b5 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -77,6 +77,7 @@ file(COPY
DESTINATION data)
add_subdirectory(core_tests)
+add_subdirectory(fuzz)
add_subdirectory(crypto)
add_subdirectory(functional_tests)
add_subdirectory(performance_tests)
@@ -114,6 +115,7 @@ set(enabled_tests
hash
performance_tests
core_proxy
+ fuzz
unit_tests)
add_custom_target(tests DEPENDS enabled_tests)