aboutsummaryrefslogtreecommitdiff
path: root/src/gen_multisig/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-06-30 17:36:31 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-12-17 16:12:06 +0000
commitfff871a455a7829d2ccbceb04306365b30bd641e (patch)
tree33d5e595b94075d7e3625a795186c83b0c3119f1 /src/gen_multisig/CMakeLists.txt
parentwallet2: allow empty wallet filename to avoid saving data (diff)
downloadmonero-fff871a455a7829d2ccbceb04306365b30bd641e.tar.xz
gen_multisig: generates multisig wallets if participants trust each other
Diffstat (limited to 'src/gen_multisig/CMakeLists.txt')
-rw-r--r--src/gen_multisig/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/src/gen_multisig/CMakeLists.txt b/src/gen_multisig/CMakeLists.txt
new file mode 100644
index 000000000..ff3c46862
--- /dev/null
+++ b/src/gen_multisig/CMakeLists.txt
@@ -0,0 +1,54 @@
+# Copyright (c) 2017, The Monero Project
+#
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification, are
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of source code must retain the above copyright notice, this list of
+# conditions and the following disclaimer.
+#
+# 2. Redistributions in binary form must reproduce the above copyright notice, this list
+# of conditions and the following disclaimer in the documentation and/or other
+# materials provided with the distribution.
+#
+# 3. Neither the name of the copyright holder nor the names of its contributors may be
+# used to endorse or promote products derived from this software without specific
+# prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
+# THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
+# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+set(gen_multisig_sources
+ gen_multisig.cpp)
+
+monero_add_executable(gen_multisig
+ ${gen_multisig_sources})
+target_link_libraries(gen_multisig
+ PRIVATE
+ wallet
+ cryptonote_core
+ cncrypto
+ common
+ epee
+ ${EPEE_READLINE}
+ ${Boost_CHRONO_LIBRARY}
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${Boost_FILESYSTEM_LIBRARY}
+ ${Boost_THREAD_LIBRARY}
+ ${Readline_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES})
+add_dependencies(gen_multisig
+ version)
+set_property(TARGET gen_multisig
+ PROPERTY
+ OUTPUT_NAME "monero-gen-trusted-multisig")
+install(TARGETS gen_multisig DESTINATION bin)