aboutsummaryrefslogtreecommitdiff
path: root/src/cryptonote_core/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-09-17 13:59:29 -0400
committerredfish <redfish@galactica.pw>2016-09-18 02:56:26 -0400
commite1c7af35d47c6f54628418f67128074c1bcd4858 (patch)
tree70bc29dbab48ac5e7d6c1b51dbbe0974704e7214 /src/cryptonote_core/CMakeLists.txt
parentcrypto: armv7: slow-hash: remove redundant source include (diff)
downloadmonero-e1c7af35d47c6f54628418f67128074c1bcd4858.tar.xz
cmake: transitive deps and remove deprecated LINK_*
Keep the immediate direct deps at the library that depends on them, declare deps as PUBLIC so that targets that link against that library get the library's deps as transitive deps. Break dep cycle between blockchain_db <-> crytonote_core. No code refactoring, just hide cycle from cmake so that it doesn't complain (cycles are allowed only between static libs, not shared libs). This is in preparation for supproting BUILD_SHARED_LIBS cmake built-in option for building internal libs as shared.
Diffstat (limited to 'src/cryptonote_core/CMakeLists.txt')
-rw-r--r--src/cryptonote_core/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/cryptonote_core/CMakeLists.txt b/src/cryptonote_core/CMakeLists.txt
index 4ebfd01e3..89bf2f682 100644
--- a/src/cryptonote_core/CMakeLists.txt
+++ b/src/cryptonote_core/CMakeLists.txt
@@ -73,7 +73,7 @@ bitmonero_add_library(cryptonote_core
${cryptonote_core_headers}
${cryptonote_core_private_headers})
target_link_libraries(cryptonote_core
- LINK_PUBLIC
+ PUBLIC
common
crypto
otshell_utils
@@ -82,9 +82,9 @@ target_link_libraries(cryptonote_core
${Boost_DATE_TIME_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY}
${Boost_SERIALIZATION_LIBRARY}
- LINK_PRIVATE
- ${Blocks}
${Boost_FILESYSTEM_LIBRARY}
${Boost_SYSTEM_LIBRARY}
${Boost_THREAD_LIBRARY}
+ PRIVATE
+ ${Blocks}
${EXTRA_LIBRARIES})