aboutsummaryrefslogtreecommitdiff
path: root/src/cryptonote_basic/CMakeLists.txt
diff options
context:
space:
mode:
authoranon <anon [at] nowhere>2021-04-27 12:06:42 +0000
committerselsta <selsta@sent.at>2021-07-13 08:00:20 +0200
commitfe76d7dee7c8ddd7bb6d32cfc7aeedda9d84572e (patch)
treef3eb43648ff242c00842dcba516aa2c5c43fcabc /src/cryptonote_basic/CMakeLists.txt
parentcmake: forbid undefined symbols (diff)
downloadmonero-fe76d7dee7c8ddd7bb6d32cfc7aeedda9d84572e.tar.xz
cmake: fix undefined symbols and multiple definitions
Diffstat (limited to 'src/cryptonote_basic/CMakeLists.txt')
-rw-r--r--src/cryptonote_basic/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/cryptonote_basic/CMakeLists.txt b/src/cryptonote_basic/CMakeLists.txt
index c9fb1433c..e386ec4ea 100644
--- a/src/cryptonote_basic/CMakeLists.txt
+++ b/src/cryptonote_basic/CMakeLists.txt
@@ -36,6 +36,14 @@ if(APPLE)
endif()
endif()
+monero_add_library(cryptonote_format_utils_basic
+ cryptonote_format_utils_basic.cpp
+)
+target_link_libraries(cryptonote_format_utils_basic
+ PUBLIC
+ cncrypto
+)
+
set(cryptonote_basic_sources
account.cpp
connection_context.cpp
@@ -74,6 +82,7 @@ target_link_libraries(cryptonote_basic
common
cncrypto
checkpoints
+ cryptonote_format_utils_basic
device
${Boost_DATE_TIME_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY}