aboutsummaryrefslogtreecommitdiff
path: root/src/cryptonote_basic/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2017-03-10 14:27:29 +0000
committerRiccardo Spagni <ric@spagni.net>2017-03-10 14:27:29 +0000
commit8fcede28df1df76c7b4e9bed386ab7e769a14447 (patch)
treed8e49fa7cc68b84e46b59c203fcbedbf9e95a3cd /src/cryptonote_basic/CMakeLists.txt
parentMerge pull request #1852 (diff)
parentfix dependency: put HardFork back to cryptonote_basic, made some BlockchainDB... (diff)
downloadmonero-8fcede28df1df76c7b4e9bed386ab7e769a14447.tar.xz
Merge pull request #1853
7d07c64f fix dependency: put HardFork back to cryptonote_basic, made some BlockchainDB functions virtual again to avoid missing symbols error (kenshi84)
Diffstat (limited to 'src/cryptonote_basic/CMakeLists.txt')
-rw-r--r--src/cryptonote_basic/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/cryptonote_basic/CMakeLists.txt b/src/cryptonote_basic/CMakeLists.txt
index db478c690..2b8ad365a 100644
--- a/src/cryptonote_basic/CMakeLists.txt
+++ b/src/cryptonote_basic/CMakeLists.txt
@@ -32,6 +32,7 @@ set(cryptonote_basic_sources
cryptonote_basic_impl.cpp
cryptonote_format_utils.cpp
difficulty.cpp
+ hardfork.cpp
miner.cpp)
set(cryptonote_basic_headers)
@@ -47,6 +48,7 @@ set(cryptonote_basic_private_headers
cryptonote_format_utils.h
cryptonote_stat_info.h
difficulty.h
+ hardfork.h
miner.h
tx_extra.h
verification_context.h)