aboutsummaryrefslogtreecommitdiff
path: root/src/crypto/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-02-21 19:14:19 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-02-22 15:51:07 +0000
commit773509ddd8f2b35a3a7f3e0a0414317be821b0ad (patch)
tree63cf135e2ff89e4ff41bd0d8edde1cfaf608ca63 /src/crypto/CMakeLists.txt
parentcmake: ARCH_ID fixes for cross compilation (diff)
downloadmonero-773509ddd8f2b35a3a7f3e0a0414317be821b0ad.tar.xz
slow-hash: fix build on arm
Diffstat (limited to 'src/crypto/CMakeLists.txt')
-rw-r--r--src/crypto/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/crypto/CMakeLists.txt b/src/crypto/CMakeLists.txt
index 5ce43be22..6e774b8d5 100644
--- a/src/crypto/CMakeLists.txt
+++ b/src/crypto/CMakeLists.txt
@@ -46,9 +46,12 @@ set(crypto_sources
skein.c
slow-hash.c
CryptonightR_JIT.c
- CryptonightR_template.S
tree-hash.c)
+if(ARCH_ID STREQUAL "i386" OR ARCH_ID STREQUAL "x86_64" OR ARCH_ID STREQUAL "x86-64")
+list(APPEND crypto_sources CryptonightR_template.S)
+endif()
+
set(crypto_headers)
set(crypto_private_headers