aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/unbound.mk
diff options
context:
space:
mode:
authorHoward Chu <hyc@symas.com>2022-05-09 19:47:33 +0100
committerHoward Chu <hyc@symas.com>2022-05-10 21:06:03 +0100
commit5c27fd853f17d12ae6ab94cb01e3ced7cc710e1c (patch)
tree0e5292ea87994cb9e47f48af3fa7ae29db3277d9 /contrib/depends/packages/unbound.mk
parentUpdate randomx: fix Mac linking error (diff)
downloadmonero-5c27fd853f17d12ae6ab94cb01e3ced7cc710e1c.tar.xz
depends: Package cleanup
All patching should be in _preprocess_cmd. config_cmd should just run configure and nothing else before it, otherwise $PATH is broken when it runs. Also remove redundant settings to configure, _autoconf already sets them. We leave explicit AR_FLAGS settings because the builtin rule uses ARFLAGS, and so would leave AR_FLAGS unset otherwise.
Diffstat (limited to 'contrib/depends/packages/unbound.mk')
-rw-r--r--contrib/depends/packages/unbound.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/contrib/depends/packages/unbound.mk b/contrib/depends/packages/unbound.mk
index 2d870d63f..06504a7cb 100644
--- a/contrib/depends/packages/unbound.mk
+++ b/contrib/depends/packages/unbound.mk
@@ -13,7 +13,7 @@ define $(package)_set_vars
endef
define $(package)_config_cmds
- $($(package)_autoconf) $($(package)_config_opts)
+ $($(package)_autoconf)
endef
define $(package)_build_cmds