aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/hidapi.mk
diff options
context:
space:
mode:
authorHoward Chu <hyc@symas.com>2022-05-09 19:47:33 +0100
committerHoward Chu <hyc@symas.com>2022-05-10 21:06:03 +0100
commit5c27fd853f17d12ae6ab94cb01e3ced7cc710e1c (patch)
tree0e5292ea87994cb9e47f48af3fa7ae29db3277d9 /contrib/depends/packages/hidapi.mk
parentUpdate randomx: fix Mac linking error (diff)
downloadmonero-5c27fd853f17d12ae6ab94cb01e3ced7cc710e1c.tar.xz
depends: Package cleanup
All patching should be in _preprocess_cmd. config_cmd should just run configure and nothing else before it, otherwise $PATH is broken when it runs. Also remove redundant settings to configure, _autoconf already sets them. We leave explicit AR_FLAGS settings because the builtin rule uses ARFLAGS, and so would leave AR_FLAGS unset otherwise.
Diffstat (limited to 'contrib/depends/packages/hidapi.mk')
-rw-r--r--contrib/depends/packages/hidapi.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/contrib/depends/packages/hidapi.mk b/contrib/depends/packages/hidapi.mk
index 55dd65006..97e204f17 100644
--- a/contrib/depends/packages/hidapi.mk
+++ b/contrib/depends/packages/hidapi.mk
@@ -9,7 +9,6 @@ $(package)_patches=missing_win_include.patch
define $(package)_set_vars
$(package)_config_opts=--enable-static --disable-shared
$(package)_config_opts+=--prefix=$(host_prefix)
-$(package)_config_opts_darwin+=RANLIB="$(host_prefix)/native/bin/$(host)-ranlib" AR="$(host_prefix)/native/bin/$(host)-ar" CC="$(host_prefix)/native/bin/$($(package)_cc)"
$(package)_config_opts_linux+=libudev_LIBS="-L$(host_prefix)/lib -ludev"
$(package)_config_opts_linux+=libudev_CFLAGS=-I$(host_prefix)/include
$(package)_config_opts_linux+=libusb_LIBS="-L$(host_prefix)/lib -lusb-1.0"
@@ -18,12 +17,11 @@ $(package)_config_opts_linux+=--with-pic
endef
define $(package)_preprocess_cmds
- patch -p1 < $($(package)_patch_dir)/missing_win_include.patch
+ patch -p1 < $($(package)_patch_dir)/missing_win_include.patch && ./bootstrap
endef
define $(package)_config_cmds
- ./bootstrap &&\
- $($(package)_autoconf) $($(package)_config_opts) AR_FLAGS=$($(package)_arflags)
+ $($(package)_autoconf) AR_FLAGS=$($(package)_arflags)
endef
define $(package)_build_cmds