aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2020-06-14 14:03:18 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2020-06-14 14:03:18 +0000
commitc4b74208c7612c336eabb4f66bd2922621d6636e (patch)
treedcbd935c1ad92509ed41801ac159c5330f46341f /CMakeLists.txt
parentfix leaks in fuzz tests (diff)
downloadmonero-c4b74208c7612c336eabb4f66bd2922621d6636e.tar.xz
Do not use PIE with OSS-Fuzz
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4fcf782aa..45a6aa1b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -652,7 +652,7 @@ else()
endif()
# linker
- if (NOT SANITIZE AND NOT (WIN32 AND (CMAKE_C_COMPILER_ID STREQUAL "GNU" AND CMAKE_C_COMPILER_VERSION VERSION_LESS 9.1)))
+ if (NOT SANITIZE AND NOT OSSFUZZ AND NOT (WIN32 AND (CMAKE_C_COMPILER_ID STREQUAL "GNU" AND CMAKE_C_COMPILER_VERSION VERSION_LESS 9.1)))
# PIE executables randomly crash at startup with ASAN
# Windows binaries die on startup with PIE when compiled with GCC <9.x
add_linker_flag_if_supported(-pie LD_SECURITY_FLAGS)