aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Michaels <mikezackles@gmail.com>2014-08-06 12:42:24 -0400
committerRiccardo Spagni <ric@spagni.net>2014-09-15 22:27:16 +0200
commita31d6bb9fbc9b8b922bf40abd943eddeff3d6ff9 (patch)
tree95d9c37ff4ca75d84d0fff0f3993178cd3b21366 /CMakeLists.txt
parentIgnore another warning to make mingw happy (diff)
downloadmonero-a31d6bb9fbc9b8b922bf40abd943eddeff3d6ff9.tar.xz
Hack to allow toolchains to pass flags to mingw
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 79e0152ef..dbbd097b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -99,7 +99,7 @@ else()
endif()
if(MINGW)
set(WARNINGS "${WARNINGS} -Wno-error=unused-value -Wno-error=unused-but-set-variable")
- set(MINGW_FLAG "-DWIN32_LEAN_AND_MEAN")
+ set(MINGW_FLAG "${MINGW_FLAG} -DWIN32_LEAN_AND_MEAN")
include_directories(SYSTEM src/platform/mingw)
else()
set(MINGW_FLAG "")