aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Michaels <mikezackles@gmail.com>2014-08-06 12:27:16 -0400
committerRiccardo Spagni <ric@spagni.net>2014-09-15 22:22:31 +0200
commit8d6a04a9f089cb656debb6b8397947f815d65f12 (patch)
treeb35f9d340fc4338059bbe67a6c1fc73cf43977c1 /CMakeLists.txt
parentMerge pull request #141 (diff)
downloadmonero-8d6a04a9f089cb656debb6b8397947f815d65f12.tar.xz
Default to static linking on both MSVC and MINGW
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 099737212..e3a08a6d6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,7 +63,12 @@ if(APPLE)
include_directories(SYSTEM /usr/include/malloc)
endif()
-set(STATIC ${MSVC} CACHE BOOL "Link libraries statically")
+if(MSVC OR MINGW)
+ set(DEFAULT_STATIC true)
+else()
+ set(DEFAULT_STATIC false)
+endif()
+set(STATIC ${DEFAULT_STATIC} CACHE BOOL "Link libraries statically")
if (UNIX AND NOT APPLE)
# Note that at the time of this writing the -Wstrict-prototypes flag added below will make this fail