aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2015-07-09 14:53:14 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2015-07-09 14:56:20 +0100
commit86234921506944dddab4e2f5edf96bf747be6c73 (patch)
tree9282b73de3c683a530f95a5d8f075d761143994f /CMakeLists.txt
parentMerge pull request #329 (diff)
downloadmonero-86234921506944dddab4e2f5edf96bf747be6c73.tar.xz
Interpret x86_64 as x86-64 for architecture
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 805b42a79..b52ea8f41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -211,7 +211,11 @@ else()
if(ARCH STREQUAL "default")
set(ARCH_FLAG "")
else()
- set(ARCH_FLAG "-march=${ARCH}")
+ if(ARCH STREQUAL "x86_64")
+ set(ARCH_FLAG "-march=x86-64")
+ else()
+ set(ARCH_FLAG "-march=${ARCH}")
+ endif()
endif()
set(WARNINGS "-Wall -Wextra -Wpointer-arith -Wundef -Wvla -Wwrite-strings -Wno-error=extra -Wno-error=deprecated-declarations -Wno-error=sign-compare -Wno-error=strict-aliasing -Wno-error=type-limits -Wno-unused-parameter -Wno-error=unused-variable -Wno-error=undef -Wno-error=uninitialized")
if(CMAKE_C_COMPILER_ID STREQUAL "Clang")