aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRandi Joseph <randi@codehalo.com>2016-12-23 02:54:34 -0500
committerRandi Joseph <randi@codehalo.com>2016-12-23 02:54:34 -0500
commit52db01ea6d1e75dd88426f5144148c74e7356948 (patch)
tree4b0be95f4bf172e30442cd11fdbc9a5c8dda3218 /CMakeLists.txt
parentMerge pull request #1487 (diff)
downloadmonero-52db01ea6d1e75dd88426f5144148c74e7356948.tar.xz
Silence CMake policy warning on macos.
See: https://cmake.org/cmake/help/v3.0/policy/CMP0042.html
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 87a53c368..e6e4afb62 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -174,6 +174,9 @@ include_directories(src contrib/epee/include external "${CMAKE_BINARY_DIR}/versi
if(APPLE)
include_directories(SYSTEM /usr/include/malloc)
+ if(POLICY CMP0042)
+ cmake_policy(SET CMP0042 NEW)
+ endif()
endif()
if(MSVC OR MINGW)