aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-08-28 06:53:46 -0400
committerredfish <redfish@galactica.pw>2016-08-28 19:39:00 -0400
commit442adfbfaa4a040bf07142dd97d71945c87c599a (patch)
tree2bc6f9a992b652f466d1da0d9a7eb0d16490e2d1 /CMakeLists.txt
parentMerge pull request #1000 (diff)
downloadmonero-442adfbfaa4a040bf07142dd97d71945c87c599a.tar.xz
cmake: define a default build type
Lets 'cmake .. && make' be sufficient to build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5b382264b..ff1590860 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,11 @@ function (die msg)
message(FATAL_ERROR "${BoldRed}${msg}${ColourReset}")
endfunction ()
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE Release CACHE STRING "Build type" FORCE)
+ message(STATUS "Setting default build type: ${CMAKE_BUILD_TYPE}")
+endif()
+
# ARCH defines the target architecture, either by an explicit identifier or
# one of the following two keywords. By default, ARCH a value of 'native':
# target arch = host arch, binary is not portable. When ARCH is set to the