aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Winget <tewinget@gmail.com>2015-01-18 18:30:31 -0500
committerThomas Winget <tewinget@gmail.com>2015-01-18 18:30:31 -0500
commit34883599bc74e8b98795fd2df24d306fe8aa1cca (patch)
tree40eb3828fa656da38ae173129199031cd0836fe0 /CMakeLists.txt
parentInitial import of lmdb source (diff)
downloadmonero-34883599bc74e8b98795fd2df24d306fe8aa1cca.tar.xz
Add in-source lmdb to build process
Working on Linux, needs verified for other platforms but should be fine.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee5d5f2ce..632eecbd8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -138,7 +138,10 @@ link_directories(${UNBOUND_LIBRARY_DIRS})
# Final setup for rapidjson
include_directories(external/rapidjson)
-find_package(LMDB REQUIRED)
+
+add_subdirectory(db_drivers)
+
+# Final setup for liblmdb
include_directories(${LMDB_INCLUDE})
if(MSVC)