aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorluigi1111 <luigi1111w@gmail.com>2019-07-24 13:53:52 -0500
committerluigi1111 <luigi1111w@gmail.com>2019-07-24 13:53:52 -0500
commit2117d0680a9f8f120423e2d74de581ed5d7d8201 (patch)
tree0155e6bad9bad8e5d31e0d1b5f3ef0e7f9a64ba9 /CMakeLists.txt
parentMerge pull request #5460 (diff)
parentCMakeLists.txt: suggest to update all submodules if one of them is outdated (diff)
downloadmonero-2117d0680a9f8f120423e2d74de581ed5d7d8201.tar.xz
Merge pull request #5472
2e514b8 CMakeLists.txt: suggest to update all submodules if one of them is outdated (erciccione)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf6955306..54bc948e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -187,7 +187,7 @@ if(NOT MANUAL_SUBMODULES)
if (upToDate)
message(STATUS "Submodule '${relative_path}' is up-to-date")
else()
- message(FATAL_ERROR "Submodule '${relative_path}' is not up-to-date. Please update with\ngit submodule update --init --force ${relative_path}\nor run cmake with -DMANUAL_SUBMODULES=1")
+ message(FATAL_ERROR "Submodule '${relative_path}' is not up-to-date. Please update all submodules with\ngit submodule update --init --force\nor run cmake with -DMANUAL_SUBMODULES=1\n")
endif()
endfunction ()