summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/arcanist/ChangeLog6
-rw-r--r--www-client/arcanist/Manifest3
-rw-r--r--www-client/arcanist/arcanist-20151003.ebuild141
3 files changed, 149 insertions, 1 deletions
diff --git a/www-client/arcanist/ChangeLog b/www-client/arcanist/ChangeLog
index ef4c1639..8137b549 100644
--- a/www-client/arcanist/ChangeLog
+++ b/www-client/arcanist/ChangeLog
@@ -1,3 +1,9 @@
+*arcanist-20151003 (08 Oct 2015)
+
+ 08 Oct 2015; Bertrand Jacquin <bertrand@jacquin.bzh>
+ +arcanist-20151003.ebuild:
+ www-client/arcanist: Version bump
+
15 Aug 2015; Bertrand Jacquin <bertrand@jacquin.bzh> arcanist-20150414.ebuild,
arcanist-20150724.ebuild, arcanist-20150815.ebuild, arcanist-9999.ebuild:
Remove malformed Id headers
diff --git a/www-client/arcanist/Manifest b/www-client/arcanist/Manifest
index dccdece0..86546a46 100644
--- a/www-client/arcanist/Manifest
+++ b/www-client/arcanist/Manifest
@@ -1,6 +1,7 @@
EBUILD arcanist-20150414.ebuild 3825 SHA256 f1fa8807da60af86500abd5899f79ef6efc0c3232f722c37d08fd76f6f11f430 WHIRLPOOL 574a6d75b5b6d71f736b71b4121a9e1d8db36ac31e0e54218eeff2108c952795952b9f49123cde9d7b4b3c45511c29628e63791b1c76597f1e2cf07f29741a00
EBUILD arcanist-20150724.ebuild 3771 SHA256 8937b161d65f574c7c6824e9315a64a3945673555fe4d042f9338fd0d2c28023 WHIRLPOOL bc1de98faac494836fca7fdb57708ac2763a6058009c43825433f4ad3c0c9141cb67ab626fbf73f52e4e12bfcba2514a76b90aa26fbca782f13d55448f265abf
EBUILD arcanist-20150815.ebuild 3771 SHA256 39a44fe09a70b887642726416fd5ae14569307d6e38e75d2b4ac9f64b230044e WHIRLPOOL db968e34868bb10a7fdc026eaa31f1fc4913fadb58e24e8c053977f8550ceaaf256255a3ae957a0ba425a294cb57df1f888658b87b10afc54947a347aabd3fcd
+EBUILD arcanist-20151003.ebuild 3771 SHA256 ee9c1d7cd56ab3fc23f7107f28351817bd468e59e57463c0029a900202b2cea7 WHIRLPOOL ec0d262abecc16398a928e15e35ec1b40b8f4c02fc93632d43a8d7909ab0412e9915dcfb155047cd45d22353ed16a6b04b61b28b5242b939f14448a29e4fefd7
EBUILD arcanist-9999.ebuild 3653 SHA256 13cf626d43c03f547a1d5ae6bc7e899687389641f1402ccd53a358e19362339d WHIRLPOOL e7a341e928800f9379b7eb7eb3e59fa635adccf46da9c26120e3652f3f82b050cccdbe6d6f8da96fc27d5fa04185f55ae621b1cb3de2c9c75dc4e917b3b4851c
-MISC ChangeLog 3181 SHA256 827c306c163699de6251a5f6c2b79d42a28fc7f9da921431c24dd4781c685676 WHIRLPOOL 6d619b49c955cfe28eeb1c0b673642d8fcadc02c206381229aecdeff5ad0e28cc00c6bb3214c75f63d9e0b3cf01805128b726a31d780e609b68a7cf8f4ba8964
+MISC ChangeLog 3336 SHA256 8aa40887a55cd02a7b76c6e5b816d2ca1974a78d4071b6718f813198de4733fb WHIRLPOOL 3ea43361f2d8a6991fd36e0f805f22f434f959abe079dc93be9969d4c16231a1fa9f0fa1d1d3b5d9a0ca9203b02c4b364a9cc5ed96c45378bd1c4dc1fa345d8b
MISC metadata.xml 452 SHA256 2e925bb81450c955ffb47c6af0cfccff61d103c2622101ee5fc225eac0407d59 WHIRLPOOL 757211efd5b90e2c231b585b3b06e5399fa5407bddcf80cd457796a09239c88a48313a5d75ea98ad538ed3aa73bfa080676570f42ea92817c2a4183526006045
diff --git a/www-client/arcanist/arcanist-20151003.ebuild b/www-client/arcanist/arcanist-20151003.ebuild
new file mode 100644
index 00000000..6a5ec611
--- /dev/null
+++ b/www-client/arcanist/arcanist-20151003.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ncurses"
+
+inherit bash-completion-r1 python-single-r1 git-r3
+
+DESCRIPTION="Command-line tool for Phabricator"
+HOMEPAGE="http://www.phabricator.org"
+EGIT_REPO_URI="git://github.com/phacility/arcanist.git"
+EGIT_BRANCH="stable"
+EGIT_COMMIT="742327128f4e2f2c2ae9bd58ffcb58b57f15cecc"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="git lint mercurial subversion ssl test abi_x86_x32"
+REQUIRED_USE="test? ( lint )"
+
+DEPEND="virtual/awk:0
+ test? (
+ >=dev-lang/php-5.2.3[xmlwriter]
+ =dev-php/libphutil-20151003:0[test]
+ )"
+RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
+ =dev-php/libphutil-20151003:0[ssl?]
+ git? ( dev-vcs/git:0 )
+ mercurial? ( dev-vcs/mercurial:0 )
+ subversion? ( dev-vcs/subversion:0 )
+ lint? (
+ app-admin/puppet-lint:0
+ dev-haskell/hlint:0
+ dev-php/PEAR-PHP_CodeSniffer:0
+ dev-python/pylint:0[${PYTHON_USEDEP}]
+ dev-python/flake8:0[${PYTHON_USEDEP}]
+ dev-util/cppcheck:0
+ dev-util/cpplint:0
+ !abi_x86_x32? ( net-libs/nodejs:0[npm] )
+ )"
+
+src_test() {
+ einfo "Note that you need to install some Node JS script manually:"
+ einfo " npm install -g coffeelint"
+ einfo " npm install -g csslint"
+ einfo " npm install -g jscs"
+ einfo " npm install -g jshint"
+ einfo " npm install -g jsonlint"
+ einfo " npm install -g less"
+
+ local GIT_NAME="${FUNCNAME} for ${CATEGORY}/${PF}"
+ local GIT_EMAIL="portage@localhost"
+
+ export GIT_AUTHOR_NAME="${GIT_NAME}"
+ export GIT_AUTHOR_EMAIL="${GIT_EMAIL}"
+
+ export GIT_COMMITTER_NAME="${GIT_NAME}"
+ export GIT_COMMITTER_EMAIL="${GIT_EMAIL}"
+
+ # Unable to locate binary "golint" to run linter ArcanistGoLintLinter. You may need to install the binary, or adjust your linter configuration.
+ # TO INSTALL: Install Golint using `go get github.com/golang/lint/golint`.
+
+ # Set config in .git/arc/config for ArcanistPyLintLinter
+ bin/arc set-config --local lint.pylint.codes.advice '^(C|R).*' > /dev/null
+ bin/arc set-config --local lint.pylint.codes.error '^(E|F).*' > /dev/null
+ bin/arc set-config --local lint.pylint.codes.warning '^W.*' > /dev/null
+
+ # + https://secure.phabricator.com/T7170
+
+ bin/arc unit --everything --no-coverage || die "arc unit failed"
+}
+
+src_prepare() {
+ echo "${EGIT_VERSION}" > "${S}/VERSION"
+
+ find "${S}" -type f -name .gitignore -print0 \
+ | xargs -0 --no-run-if-empty -- \
+ rm
+
+ rm bin/*.bat
+
+ # Replace 'env' shebang to files it point to
+ find "${S}" -type f \
+ | sort \
+ | xargs -n 1 --no-run-if-empty -- \
+ awk 'NR == 1 && /^#!\/usr\/bin\/env/ {print FILENAME}' \
+ | while read ; do
+ set -- $(sed -ne '1 s:^#!\([^ ]*\) ::p;q' ${REPLY})
+ cmd="$1" ; shift ; args="$@"
+
+ case "${cmd}" in
+ bash|php) ;;
+ *) continue ;;
+ esac
+
+ path="$(type -p ${cmd})" || continue
+ [[ -z "${path}" ]] && continue
+
+ einfo "Replace ${REPLY/#${S}\/} shebang to #!${path} ${args}"
+ sed -i \
+ -e "1 s:^#!.*:#!${path} ${args}:" \
+ "${REPLY}"
+ eend $?
+ done
+}
+
+src_install() {
+ newbashcomp resources/shell/bash-completion "arc"
+
+ insinto "/usr/share/${PN}"
+ doins VERSION
+
+ insinto "/usr/share/php/${PN}"
+ doins -r bin externals resources scripts src
+
+ python_scriptinto "/usr/share/php/${PN}/scripts"
+ python_doscript scripts/breakout.py
+
+ # Make executable all shebanged files
+ find "${ED}" -type f \
+ | xargs -n 1 --no-run-if-empty -- \
+ awk 'NR == 1 && /^#!/ {print FILENAME}' \
+ | sed -e "s:${ED}:/:" \
+ | xargs --no-run-if-empty -- \
+ fperms 755
+
+ dosym "/usr/share/php/${PN}/bin/arc" /usr/bin/arc
+
+ dodoc NOTICE README.md
+}
+
+pkg_postinst() {
+ if use lint; then
+ elog
+ elog "Some linter need external NodeJS script. To install them, use:"
+ elog " npm install -g csslint"
+ fi
+}