summaryrefslogtreecommitdiff
path: root/www-client
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/arcanist/ChangeLog3
-rw-r--r--www-client/arcanist/Manifest4
-rw-r--r--www-client/arcanist/arcanist-9999.ebuild15
3 files changed, 10 insertions, 12 deletions
diff --git a/www-client/arcanist/ChangeLog b/www-client/arcanist/ChangeLog
index 130a291a..7b3353fc 100644
--- a/www-client/arcanist/ChangeLog
+++ b/www-client/arcanist/ChangeLog
@@ -1,3 +1,6 @@
+ 22 Aug 2013; Bertrand Jacquin <beber@meleeweb.net> arcanist-9999.ebuild:
+ www-client/arcanist: Remove test USE flag, always install them
+
15 Aug 2013; Bertrand Jacquin <beber@meleeweb.net> arcanist-9999.ebuild:
www-client/arcanist: Empty KEYWORDS for live ebuild
diff --git a/www-client/arcanist/Manifest b/www-client/arcanist/Manifest
index bbc38bcd..935940e2 100644
--- a/www-client/arcanist/Manifest
+++ b/www-client/arcanist/Manifest
@@ -1,3 +1,3 @@
-EBUILD arcanist-9999.ebuild 2056 SHA256 01914ac516f5ca3ccbe036de84e2642d32926fe6752acfe9054dbb144357bfda WHIRLPOOL 09e48f8ba7abaee48f779124710b8223c1ebcd30ad98e2457319e1a63eafa2c169f70947ef5e757f939c7158ca60db597a171918e4f1fe1e061acbb2b8ae5a48
-MISC ChangeLog 636 SHA256 b50a2cf07a646216da00b3612df5b1d46b09a5763b676b2d41099393ae22b192 WHIRLPOOL e6d53d725dfdb5e524f2e4925d7790308ac1de29e717a66f925cbf5a7518bcdc372884376574809fa8207284dae424410dfd9c5bdb1a7de72ec117a396831062
+EBUILD arcanist-9999.ebuild 1934 SHA256 06ad05f60d1dd11a0562b01bd465dda12891b31afc3b047b262d700f51c3f9ec WHIRLPOOL c3513888fc650bbd1ed470851aa7ee6e17ca940cadb2d2120fa5d25686cd0a886c637e60fad2b0633e624415b746a253584247dd2332e0a4b75ae5bd61cc91f7
+MISC ChangeLog 777 SHA256 d87abccce415366efdf34ab2dc1dd1cea011049f53c1fc31ffa8461021467558 WHIRLPOOL 4a7f73167aa937b79323b5d633710d79ea53c0ff6cdeb23fdc84efb8679c2eb3a360e44e37c703d61f8208005eea883fb01ab384d2ba8ffbb6bc06855b2889f7
MISC metadata.xml 376 SHA256 214868e07f83e61d21087c9867be82c69039947d2f6e29d5d0facf23e7690a4d WHIRLPOOL 34de8852dfdb73e442aba0c8b52cb6bc7877ca7d9b922245d25861935d69882cebeb9a3220dadd2b0f8548f6b16d10bb2c95017eda5d5f7b96cc6af7eadb484d
diff --git a/www-client/arcanist/arcanist-9999.ebuild b/www-client/arcanist/arcanist-9999.ebuild
index c04bcab0..8c5f6252 100644
--- a/www-client/arcanist/arcanist-9999.ebuild
+++ b/www-client/arcanist/arcanist-9999.ebuild
@@ -12,7 +12,7 @@ EGIT_REPO_URI="git://github.com/facebook/arcanist.git"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="css git javascript mercurial php python subversion ssl test"
+IUSE="css git javascript mercurial php python subversion ssl"
RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
=dev-php/libphutil-${PV}[ssl?]
@@ -27,19 +27,13 @@ RDEPEND=">=dev-lang/php-5.2.3[cli,curl,json,ssl?]
src_install() {
newbashcomp resources/shell/bash-completion "${PN}"
- rm -r scripts/hgdaemon src/hgdaemon
rm -r resources/shell
+ if ! use mercurial ; then
+ rm -r scripts/hgdaemon src/hgdaemon
+ fi
rm bin/*.bat
rm scripts/*.txt
- rm src/extensions/README
- rm externals/{,includes}/README
-
- if ! use test ; then
- find "${S}" -type d -name __tests__ \
- | xargs --no-run-if-empty -- \
- rm -r
- fi
insinto "/usr/share/php/${PN}"
doins -r bin externals scripts src
@@ -53,6 +47,7 @@ src_install() {
fperms 755
# Fix python shebang
+ # Move to python-r1
find "${ED}" -type f -name '*.py' \
| xargs --no-run-if-empty -- \
sed -i \