summaryrefslogtreecommitdiff
path: root/www-apache
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_ruid2/mod_ruid2-0.9.8.ebuild10
-rw-r--r--www-apache/mod_ruid2/mod_ruid2-9999.ebuild10
2 files changed, 16 insertions, 4 deletions
diff --git a/www-apache/mod_ruid2/mod_ruid2-0.9.8.ebuild b/www-apache/mod_ruid2/mod_ruid2-0.9.8.ebuild
index d80d85fc..5d44da59 100644
--- a/www-apache/mod_ruid2/mod_ruid2-0.9.8.ebuild
+++ b/www-apache/mod_ruid2/mod_ruid2-0.9.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,8 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
-DEPEND="sys-libs/libcap"
+DEPEND="sys-libs/libcap
+ virtual/libcrypt:="
RDEPEND="${DEPEND}"
S="${WORKDIR}/mod-ruid2-${P}"
@@ -31,6 +32,11 @@ DOCFILES="README ruid2.conf"
need_apache2
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}
+
src_compile() {
emake CC="$(tc-getCC)" V=1
}
diff --git a/www-apache/mod_ruid2/mod_ruid2-9999.ebuild b/www-apache/mod_ruid2/mod_ruid2-9999.ebuild
index 525f50f7..ee0dc7e4 100644
--- a/www-apache/mod_ruid2/mod_ruid2-9999.ebuild
+++ b/www-apache/mod_ruid2/mod_ruid2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,8 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-DEPEND="sys-libs/libcap"
+DEPEND="sys-libs/libcap
+ virtual/libcrypt:="
RDEPEND="${DEPEND}"
PATCHES=(
@@ -29,6 +30,11 @@ DOCFILES="README ruid2.conf"
need_apache2
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}
+
src_compile() {
emake CC="$(tc-getCC)" V=1
}