summaryrefslogtreecommitdiff
path: root/sys-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/alix-sources/Manifest3
-rw-r--r--sys-kernel/alix-sources/alix-sources-2.6.25-r17.ebuild52
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-kernel/alix-sources/Manifest b/sys-kernel/alix-sources/Manifest
new file mode 100644
index 00000000..03237090
--- /dev/null
+++ b/sys-kernel/alix-sources/Manifest
@@ -0,0 +1,3 @@
+DIST linux-2.6.25.tar.bz2 48601689 RMD160 cf3ed52f888fe9df7a93abe4fdc2f598e1ba0ce4 SHA1 aa6187a1c212dd2d8bd906b023fcefdcf711f35e SHA256 108b2a3f2b05c0e57d1d0977619525e46f8d4b425aef4b38b47dcf94292f2dd2
+DIST patches-2.6.25-wt17.tar.bz2 3732544 RMD160 44defc4f1b06819e5582300da574666b368a217e SHA1 8c8d43778d45ecb9d709e8a503adb0913ba72e32 SHA256 d276fa7b33a9fd63df8959332e997a74c37092b3fec5f5cdf5c97798f79f6e21
+EBUILD alix-sources-2.6.25-r17.ebuild 1247 RMD160 a2cb356d5e17002a5faec8c140bba01c94716ddd SHA1 54bb91078ee610df25265902aa8b1d9a0259f5e3 SHA256 c2017dd078724075b4f34563e759ac0fd83938cc21e6195aa687be064cf7ca09
diff --git a/sys-kernel/alix-sources/alix-sources-2.6.25-r17.ebuild b/sys-kernel/alix-sources/alix-sources-2.6.25-r17.ebuild
new file mode 100644
index 00000000..35424261
--- /dev/null
+++ b/sys-kernel/alix-sources/alix-sources-2.6.25-r17.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ETYPE="sources"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+HOMEPAGE="http://linux.1wt.eu/alix"
+
+WT_PATCHES="patches-${PVR/r/wt}.tar.bz2"
+
+DESCRIPTION="Full sources including the Willy Tarreau Alix patchset"
+SRC_URI="${KERNEL_URI}
+ http://linux.1wt.eu/alix/kernel-src/${PVR/r/wt}/${WT_PATCHES}"
+
+src_unpack () {
+ universal_unpack
+
+ debug-print "Doing unipatch"
+ pushd "${WORKDIR}" > /dev/null
+ unpack ${WT_PATCHES}
+ popd >/dev/null
+
+ cd ${WORKDIR}/${WT_PATCHES%.tar.bz2*}
+ emake numbered KERNDIR=${WORKDIR}/${P}
+
+ cd ${S}
+ epatch ${WORKDIR}/${WT_PATCHES%.tar.bz2*}/numbered/[1-9]*
+ debug-print "Doing premake"
+ [[ $(type -t kernel-2_hook_premake) == "function" ]] && kernel-2_hook_premake
+ debug-print "Doing unpack_set_extraversion"
+ [[ -z ${K_NOSETEXTRAVERSION} ]] && unpack_set_extraversion
+ unpack_fix_install_path
+
+ env_setup_xmakeopts
+ cd "${S}"
+
+ if [[ ${ETYPE} == headers ]]; then
+ kernel_is 2 4 && unpack_2_4
+ kernel_is 2 6 && unpack_2_6
+ fi
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}