summaryrefslogtreecommitdiff
path: root/sys-apps/flxutils
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/flxutils')
-rw-r--r--sys-apps/flxutils/files/remount-sstrip.diff8
-rw-r--r--sys-apps/flxutils/flxutils-0.1.31.ebuild73
2 files changed, 81 insertions, 0 deletions
diff --git a/sys-apps/flxutils/files/remount-sstrip.diff b/sys-apps/flxutils/files/remount-sstrip.diff
new file mode 100644
index 00000000..a9ca6ef5
--- /dev/null
+++ b/sys-apps/flxutils/files/remount-sstrip.diff
@@ -0,0 +1,8 @@
+--- remount/Makefile.ori 2009-04-24 13:54:14.000000000 +0200
++++ remount/Makefile 2009-04-24 13:54:59.000000000 +0200
+@@ -9,4 +9,4 @@
+ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $<
+ $(STRIP) -x --strip-unneeded -R .comment -R .note $@
+ $(OBJDUMP) -h $@ | grep -q '\.data[ ]*00000000' && $(STRIP) -R .data $@ || true
+- sstrip $@
++ -if [ -n "$(SSTRIP)" ]; then $(SSTRIP) $@ ; fi
diff --git a/sys-apps/flxutils/flxutils-0.1.31.ebuild b/sys-apps/flxutils/flxutils-0.1.31.ebuild
new file mode 100644
index 00000000..6f87639c
--- /dev/null
+++ b/sys-apps/flxutils/flxutils-0.1.31.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git
+
+DESCRIPTION="Formilux Tools"
+HOMEPAGE="http://master.formilux.org/git/dist/src/flxutils.git"
+EGIT_REPO_URI="http://master.formilux.org/git/dist/src/flxutils.git"
+EGIT_TREE="v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flx init remount"
+
+DEPEND="dev-libs/dietlibc"
+RDEPEND=""
+
+src_unpack ()
+{
+ git_src_unpack
+
+ cd ${S}
+ epatch "${FILESDIR}"/remount-sstrip.diff
+}
+
+src_compile ()
+{
+ export DIET="/usr/bin/diet"
+ export OBJDUMP="$(tc-getPROG OBJDUMP objdump ${CHOST})"
+ export STRIP="$(tc-getSTRIP)"
+
+ use flx && {
+ cd ${S}/flx
+ emake || die "emake flx failed"
+ }
+
+ use init && {
+ cd ${S}/init
+ emake \
+ SSTRIP=\"\" || die "emake init failed"
+ }
+
+ use remount && {
+ cd ${S}/remount
+ emake \
+ SSTRIP=\"\" || die "emake remount failed"
+ }
+}
+
+src_install ()
+{
+ use init && {
+ into /
+ dosbin init/init
+ dodoc init/{README,README.2}
+ }
+
+ into /usr
+ use flx && {
+ dobin flx/flx
+ dodoc flx/{AUTHORS,ChangeLog,NOTES,README,TODO}
+ }
+
+ use remount && {
+ dobin remount/remount{r,w}
+ }
+ dobin scripts/pkg
+
+ dodoc README ChangeLog
+ dodoc scripts/NOTES
+}