summaryrefslogtreecommitdiff
path: root/net-p2p/monero
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/monero')
-rw-r--r--net-p2p/monero/monero-0.14.0.2.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-p2p/monero/monero-0.14.0.2.ebuild b/net-p2p/monero/monero-0.14.0.2.ebuild
index 68687973..9d0dc524 100644
--- a/net-p2p/monero/monero-0.14.0.2.ebuild
+++ b/net-p2p/monero/monero-0.14.0.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils user
+inherit cmake-utils user systemd
DESCRIPTION="Secure, private, untraceable cryptocurrency"
HOMEPAGE="https://getmonero.org"
@@ -42,7 +42,7 @@ pkg_setup() {
enewuser monero -1 -1 /var/lib/monero monero
}
-src_configure () {
+src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION="$(usex doc ON OFF)"
-DBUILD_TESTS=OFF
@@ -58,3 +58,12 @@ src_configure () {
cmake-utils_src_configure
}
+
+src_install() {
+ cmake-utils_src_install
+
+ insinto /etc
+ doins utils/conf/monerod.conf
+
+ systemd_dounit utils/systemd/monerod.service
+}